iGalerie

Vous n'êtes pas identifié(e).

#1 Re : Installation » VirtualHost et .htaccess conflit? RewriteEngine ? » 28-08-2020 21:24:07

RV

Re-salut,

J'ai identifié le problème : j'ai "installé" igalerie3 localement et créé le VirtualHost après ... les noms des dossiers vus de l'extérieurs n'étaient pas bons!
Donc, en modifiant la valeur dans /config/conf.php :

define('CONF_GALLERY_PATH', 'test'); 

par

define('CONF_GALLERY_PATH', '');

et dans le fichier .htaccess à la racine de la galerie :

RewriteBase /test/

par

RewriteBase /

tout marche à merveille smile depuis l'extérieur uniquement sad je peux accéder à la galerie depuis son adresse publique. Depuis mon LAN, pas d'accès ni avec l'adresse IP locale ni avec celle publique ... merci à la LiveBox3 qui ne gère pas le DNS LoopBack sad

Si quelqu'un a un tuyau, je prends.

#2 Installation » VirtualHost et .htaccess conflit? RewriteEngine ? » 28-08-2020 11:57:15

RV
Réponses : 1

Salut,

En faisant quelques essais sur un raspberry équipé d'un serveur apache2 avec le VirtualHost suivant :

 
<VirtualHost *:80>
        ServerName test.mondomaine.fr
        ServerAdmin webmaster@mondomaine.fr
        DocumentRoot  /var/www/html/test/
#  ....
</VirtualHost>

je n'arrive pas à comprendre que lorsque je dépose des pages simples index.html
tout se passe bien. Le navigateur affiche dans http://test.mondomaine.fr la page index.html présente. Si je créé un dossier /var/www/html/test/test1 avec un fichier index.html dedans, l'adresse http://test.mondomaine.fr/test1 affiche bien le fichier index.html contenu dedans. Jusque là tout va bien smile

Si j'installe igalerie3 dans le répertoire /var/www/html/test/, patatras, la page d'accueil (depuis l'extérieur toujours) http://test.mondomaine.fr affiche une page sans style remplie d'erreurs 404. Chaque clic affiche "Internal Server Error" en tentant d'afficher la page http://test.mondomaine.fr/test - ce qui ne devrait pas se produire si j'ai bien compris la fonction du VirtualHost.

L'accès en local via l'adresse http://192.168.0.xxx/test fonctionne parfaitement (sans VirtualHost défini)

Mes connaissances étant ultra limitées, j'ai du rater quelque chose quelque part, mais où?
Le module rewrite dans le fichier .htaccess à la racine? Le fichier de conf du VirtualHost?
Merci
@+

#3 Utilisation » max_input_vars » 10-08-2020 20:43:36

RV
Réponses : 1

Salut,

Lors de l'importation d'un album de 396 images, j'ai eu :

#1
Date : 2020-08-10 18:33:14.047917
Version : 3.0.5
Type : PHP_WARNING
Fichier : Unknown
Ligne : 0
Page : category/1
Message : Unknown: Input variables exceeded 1000. To increase the limit change max_input_vars in php.ini.

J'ai donc modifié le fichier .htaccess à la racine d'iGalerie3 en rajoutant :

 php_value max_input_vars 3000 

à la fin.

L’erreur ne s'est pas reproduite. J'ai bon ? ou il faut vraiment que je modifie le php.ini?

#4 Re : Utilisation » Commentaire anti-flood » 06-08-2020 12:22:17

RV

Salut,

En fait j'ai effacé les valeurs des champs 'com-ip' dans la database (qui étaient toutes identiques, mon IP) et ensuite, pas de problème j'ai pu à nouveau poster des commentaires en admin ou pas.
Ensuite, j'ai essayé de reproduire le pb sans succès ... si jamais ce phénomène réapparaît je remplacerai la ligne de code et te ferai un retour.
Merci
@plouf

#5 Re : Utilisation » Commentaire anti-flood » 05-08-2020 20:14:19

RV

Salut,
Ça ne change rien, j'ai maintenant "Vous devez patienter encore 11386616 secondes avant de pouvoir poster un nouveau commentaire." !

#6 Utilisation » Commentaire anti-flood » 05-08-2020 00:05:39

RV
Réponses : 4

Salut
J'ai ça en testant les commentaires :
"Vous devez patienter encore 11459342 secondes avant de pouvoir poster un nouveau commentaire." !!!
L'anti-flood est pourtant réglé (par défaut à 15s).
Une idée?

#7 Re : Utilisation » Accents » 23-07-2020 16:33:03

RV

Salut,

J'ai appliqué la solution de tordclou pour l'installation :
http://www.igalerie.org/forum/viewtopic.php?id=3216

tordclou a écrit :

Bonjour
il manquait les droits j ai fais ceci:
$ sudo chown  -R pi:www-data /var/www/html/
$ sudo chmod -R 770 /var/www/html/

et l' install a bien fonctionné
merci

et miracle : le renommage des fichiers se passe bien

@plouf

#8 Re : Utilisation » Accents » 22-07-2020 12:12:28

RV

J'ai aussi ça :

#1
Date : 2020-07-21 21:13:57.292550
Version : 3.0.5
Type : PHP_WARNING
Fichier : includes/core/File.class.php
Ligne : 181
Page : category/1
Message : chmod(): Operation not permitted
Trace : #1 admin/index.php(18): Admin::start()#2 includes/admin/classes/Admin.class.php(792): require_once('/var/www/html/i...')#3 includes/admin/category.php(20): AdminCategory::actions()#4 includes/admin/classes/AdminCategory.class.php(60): Category::delete(Array)#5 includes/core/Category.class.php(341): File::rmdir('/var/www/html/i...')#6 includes/core/File.class.php(249): File::makeWritable('/var/www/html/i...')#7 includes/core/File.class.php(181): chmod('/var/www/html/i...', 509)

#9 Re : Utilisation » Accents » 22-07-2020 11:28:13

RV

Salut,

En fait j'ai 85 incidents de ce type :

rename(/albums/0090_Cerbere_avril_mai_2009/Cerbère_2009-04-29_09-48-08.jpg,/albums/0090_Cerbere_avril_mai_2009/Cerbere_2009-04-29_09-48-08.jpg): Permission denied

Mon dossier dans /igalerie3/abums/0090_Cerbere_avril_mai_2009 a bien la permission 775 mais pas les fichiers (photos) à l'intérieur. Si je change la permission des fichiers en 775, c'est pareil : "Renommage impossible"

Une idée?

#10 Utilisation » Accents » 21-07-2020 23:10:35

RV
Réponses : 4

Salut,
le nom de mes photos contiennent un accent "è"et ça donne ça :

"95 erreurs se sont produites.

Aucun nouvel album et aucun nouveau fichier n'a été détecté.

Aucun album n'a été mis à jour.

1 catégorie a été rejetée"

Une idée ?
@plouf

#11 Re : Discussions » Développer une extension » 05-07-2020 19:33:00

RV

Salut,
J'ai bêtement mis les balises meta dans template/default/custom/head.tpl.php en ayant rajouté la ligne préconisée dans template/default/index.tpl.php et c'est ce que je souhaitais, les balises meta se retrouvent sur toutes pages smile

Jusque là c'est parfait ! Merci!
@+

#12 Re : Discussions » 3.03 c'est la Classe » 02-07-2020 19:20:19

RV

L'image au hasard est revenue en 3.05, c'est cool smile
Par contre, à moins que j'ai raté un truc, c’est un peu déconcertant qu'elle soit en bas de la page ... surtout lorsque c'est après 500 vignettes.

#13 Re : Discussions » Développer une extension » 02-07-2020 19:12:49

RV

Pareil, je teste ça bientôt smile
Merci
Question, dans le fichier head.tpl.php je mets des balises META simplement comme ça :

<?php
if ($_GET['section'] == 'item')
{
   // Code Javascript uniquement sur la page des images.
<meta name="keywords" content="Des photos en couleur" />
}
?>

Et ça marche ? (en ayant rajouté la ligne template/default/index.tpl.php qui sera dans la prochaine version je suppose).
Je suis limité en php ...

#14 Re : Discussions » Définir un répertoire de stockage. » 01-07-2020 20:39:56

RV

Salut,

Modif effacée à chaque mise à jour?
Ce serait cool de pouvoir le définir dans l'interface admin smile

L'idée serait de prendre l'hébergement le moins cher juste pour le code php et nom de domaine et de mettre les données (photos et vidéos) volumineuses à la maison sur un nas, un san, un serveur FTP , Raspberry avec un serveur apache, ... (?) accessible via un sous-domaine du domaine principal.
Fibre requise je pense pour une telle solution...
Des avis, des conseils, des exemples, un tuto!!!
Merci
@plouf

#15 Re : Discussions » Balises Meta » 30-06-2020 23:07:34

RV

Salut,
Merci, c'est bien ce que pensais faire.
Ce serait cool de les inclure dans les options.
@+

#16 Discussions » Balises Meta » 28-06-2020 21:11:48

RV
Réponses : 3

Salut,

Comment rajouter les méta - balises
<meta name="author"
<meta name="keywords"
<meta name="copyright"
...

dans la page d'accueil de la galerie?

Seule la balise <meta name="description" est utilisée pour l'option "description de la galerie"
@+

#17 Re : Utilisation » Ne trouve pas les images » 09-06-2020 19:51:29

RV

150 000Ko ou 150Mo l'image, c'est du lourd ! smile

#18 Discussions » 3.03 c'est la Classe » 05-05-2020 20:39:47

RV
Réponses : 1

Salut,

Merci pour cette nouvelle version smile

L'image au hasard et une bannière comme sur la V2 et c'est le top du top!

@+

#19 Re : Utilisation » Barre d'adresse Firefox Android » 03-05-2020 18:03:33

RV

Trop fort! J'ai hâte de voir cette nouvelle version smile

#22 Utilisation » Barre d'adresse Firefox Android » 02-05-2020 20:32:24

RV
Réponses : 2

Salut,

N'y a-t-il pas moyen de faire disparaitre cette barre d'adresse lors du visionnage du diaporama sur smartphone? Un peu comme sur certains sites d'information (20min), la barre disparait au bout d'un moment ce qui facilite la lecture.
Cela permettrait d'avoir une image moins petite sur un écran déjà petit.

@+

#24 Propositions » Nombre vignettes par page des photos et vidéos » 20-04-2020 12:13:47

RV
Réponses : 2

salut,

Ce nombre est limité à 96 sur la V3 alors que sur la V2 j'avais pu le mette à 999 sans problème. Serait-il possible d’élever cette limite?
@+

#25 Propositions » Newsletter » 18-04-2020 19:54:16

RV
Réponses : 1

Salut,

Ce serait sympa de pouvoir s'inscrire et de recevoir un mail s'il y a des nouvelles images.

@+

Pied de page des forums

Propulsé par FluxBB