iGalerie

Vous n'êtes pas identifié(e).

#1 Utilisation » Changement vignette dans le bandeau d'accueil de la galerie » 25-12-2021 10:01:21

Denis GIRAULT
Réponses : 0

Bonjour David, impossible de me rappeler la manière de changer la vignette du bandeau d'accueil / menus de ma galerie V2. J'ai cherché partout j'ai rien (re)trouvé. Merci de me rafraichir la mémoire. Bonnes fêtes de fin d'année à toi et à ta famille.

#2 Utilisation » Vignette dans le bandeau d'Accueil / Menus » 25-12-2021 09:53:32

Denis GIRAULT
Réponses : 0

Bonjour David, est-il possible de rajouter une  vignette photo dans le bandeau d'accueil de ma galerie V3. Bonnes fêtes de fin d'année à toi et à ta famille.

#3 Bugs » Incidents Recensés » 12-05-2021 07:54:43

Denis GIRAULT
Réponses : 0

Bonjour David, en consultant l'administration de ma galerie j'ai découvert 3 Incidents recensés probablement sur la version précédente V3.0.10 ou antérieure. Je te les livre tel que :

#3
Date : 2021-04-23 23:14:01.356494
Version : 3.0.10
Type : MYSQL_ERROR
Fichier : includes/core/DB.class.php
Ligne : 196
Page : item/6623-00022
Message : SQLSTATE[HY000] [2002] Connection refused
Trace : #1 index.php(15): Gallery::start()#2 includes/gallery/classes/Gallery.class.php(287): DB::connect()

#2
Date : 2021-04-04 14:46:49.165291
Version : 3.0.10
Type : MYSQL_ERROR
Fichier : includes/core/DB.class.php
Ligne : 305
Page : 
Message : SQLSTATE[23000]: Integrity constraint violation: 1052 Column 'user_id' in from clause is ambiguous
Trace : #1 rss.php(27): RSS->makeCategoryFeed(1, 'comments')#2 includes/core/RSS.class.php(119): RSS->_getComments('item_path LIKE ...', '%')#3 includes/core/RSS.class.php(239): DB::execute('SELECT com.com_...', Array)

#1
Date : 2021-03-10 16:19:06.862065
Version : 3.0.10
Type : PHP_NOTICE
Fichier : includes/core/Zip.class.php
Ligne : 127
Page : 
Message : ob_flush(): failed to flush buffer. No buffer to flush
Trace : #1 download.php(104): Zip::archive('2019 Orgerus Ma...', Array)#2 includes/core/Zip.class.php(127): ob_flush()

Je n'ai pas le contexte de survenue de ces incidents, mais cela n'a pas eu apparement de conséquences visibles sur l'utilisation de ma galerie. Je suis prêt à refaire certaines manips si tu le juges nécessaire pour essayer de les reproduire. En tout cas un énorme merci pour tout ton travail qui apporte des améliorations permanentes. Avec aujourd'hui 4 586 photos 570 vidéos dans 211 albums, ma galerie familiale fait un tabac grâce à toi ! Amitiés.

#4 Re : Utilisation » [RESOLU] Changement de vignette vidéo instable » 16-12-2020 14:41:22

Oki Merci David c'est effectivement plus ... rapide. Message en mode Résolu

#5 Re : Discussions » [RESOLU] Répertoires TestV3 et toto utiles ? » 15-12-2020 21:38:28

C'est bien possible ;-) Je voulais m'en assurer avant tout effacement. La mémoire nous joue parfois des tours. Cordialement.

#6 Re : Utilisation » [RESOLU] Changement de vignette vidéo instable » 15-12-2020 15:24:52

Auto réponse à mon problème : piégé par le comportement de la mise à jour des vignettes des catégories ou des albums qui est effective immédiatement (rafraichissement du cache) alors que ce n'est pas le cas pour les vignettes des vidéos. La modification est bien prise en compte (affichage correct) mais le cache n'est pas rafraichi affichant l'ancienne visibilité quand on revient sur la page concernée il faut le vider manuellement dans le navigateur (Edge, Chrome ...) pour obtenir la bonne visibilité. Peut-on envisager un rechargement forcé de la page dans ce cas de modification ? Merci pour la réponse.

#7 Discussions » [RESOLU] Répertoires TestV3 et toto utiles ? » 15-12-2020 14:42:20

Denis GIRAULT
Réponses : 2

Bonjour David,
présence de deux répertoires TestV3 et toto installée au niveau de l'application iGalerie V3. Vu leur nom je me pose la question de leur utilité à ce jour de fonctionnement quasi stabilisé de ton application ? Peut-on les supprimer sans risque de dysfonctionnement ? Merci d'avance pour la réponse.

#8 Utilisation » [RESOLU] Changement de vignette vidéo instable » 15-12-2020 00:07:54

Denis GIRAULT
Réponses : 3

Bonsoir David,
Dans ma galerie j'essaie vainement de changer les vignettes de certaines vidéos qui ne conviennent pas. L'opération se passe bien : Interface d'administration sur la vidéo concernée --> nouvelle vignette --> extraire l'image --> enregistrer ( surtout ne pas appuyer une deuxième fois sur enregistrer sinon tout s'efface et il faut recommencer ) La modification est bien effective mais si on change de répertoire ou si on fait un autre changement de vignette sur une autre vidéo, au retour la modification a disparu et on est revenu à la vignette d'origine.
Aucun message d'erreur ni d'incident signalé.   
Merci de me dire si il y a un paramètre ou une utilisation particulière pour éviter ce problème.

#9 Re : Utilisation » [RESOLU] Version PHP V2 vs PHP V3 » 11-12-2020 22:40:00

Le changement de version PHP de iGalerie version 3 est maintenant visible dans les données systèmes de l'administrateur Version de PHP : 7.4.13. Le problème est résolu avec mon hébergeur IONOS.  Merci David pour cette MàJ.  Je passe ce message en résolu.

#10 Re : Propositions » [RESOLU] Ajout Statistique Vidéos pour les membres » 11-12-2020 22:06:12

Merci David, ton produit est tellement riche que la découverte de toutes ses possibilités se fait au fur et à mesure de son utilisation et avec heureusement ton aide qui remplace une doc qui pourrait faire facilement plus d'une centaine de pages ;-)
Message mis en résolu.

#11 Propositions » [RESOLU] Ajout Statistique Vidéos pour les membres » 11-12-2020 15:45:55

Denis GIRAULT
Réponses : 2

Bonjour David,
l'administrateur est le seul à accéder aux statistiques vidéos (nombres de vidéos au niveau général) par le tableau de bord (fonction administrative du super admin)
Mon album (type familial) intègre de nombreuses vidéos. Serait-il possible d'ajouter cette visibilité au niveau des membres, dans la page d'accueil de la galerie et de chaque catégorie, partie rubrique statistique, située en bas de page ? Merci d'avance pour ta réponse même si elle est négative.

#12 Utilisation » [RESOLU] Version PHP V2 vs PHP V3 » 07-12-2020 13:03:11

Denis GIRAULT
Réponses : 2

Bonjour David,
sur iGalerie V2 le niveau de PHP est PHP Version : 7.3.25
sur iGalerie V3 Version de l'application : 3.0.8 Version de PHP : 7.2.34
Peux-tu envisager le passage de cette dernière version très réussie en PHP 7.3 ?
Mon hébergeur vient de m'annoncer brutalement que "À partir de décembre 2020, la version 7.2 de PHP ne sera plus officiellement prise en charge et, par conséquent, aucune mise à jour de sécurité gratuite ne sera alors disponible pour cette version." Il me laisse un délai de 3 mois. Merci pour ta réponse et encore bravo pour cette version 3 que j'utilise régulièrement. Bonne journée.

#13 Re : Bugs » [RESOLU] Affichage du nombre de photos / vidéos absent (niveau album) » 30-11-2020 22:19:08

Oups, désolé c'était une mauvaise interprétation de la fonctionnalité de ma part. Ayant mis au départ une valeur trop importante j' obtenais effectivement pour chaque album le nombre total des photos d'où ma confusion lorsque ces valeurs ont soudain évolué. Je passe mon message en résolu. Bonne soirée David.

#14 Bugs » [RESOLU] Affichage du nombre de photos / vidéos absent (niveau album) » 30-11-2020 15:08:59

Denis GIRAULT
Réponses : 2

Bonjour David.
La vignette de certains albums n' affiche plus le nombre de photos / vidéos , ce qui entraine au niveau supérieur un mauvais comptage (et affichage) du nombre de photos / vidéos. Je n'ai hélas pas fait attention au moment où ce phénomène a commencer à se produire. J'ai visualisé les infos système : aucun incident n'est détecté. 
Ci joint les copies d'écran du problème sur ma galerie.

Racine de la Galerie :
Galerie.jpg

Une des sous-Catégorie :
Galerie2.jpg

Que faire pour rétablir les bonnes valeurs et débugger cette anomalie ? Merci pour ta réponse.

Edit de 18h45: Si pour les albums concernés, je supprime toutes les photos et je refais le transfert (par ftp), le nombre de photos réapparait au niveau de la vignette

#15 Re : Utilisation » Téléchargement photos (album ou individuelles) par Invité » 28-11-2020 23:24:17

Merci David pour ta réponse en décochant "Accès aux photos originales" pour le membre visiteur (Groupe Invité) de ma galerie celui-ci n'a maintenant plus accès aux téléchargements des photos EN TAILLE REELLE.  Il pourrait bien sûr comme tous les utilisateurs qui ne veulent pas respecter les droits d'auteur, récupérer ces photos avec le simple outil intégré dans Windows : Capture d'écran, mais il les récupèrera avec une résolution (celle de l'écran) bien moindre que celle de l'originale. Chacun ses valeurs.
J'aimerai bien mettre ce post en résolu mais les vidéos ont été oubliées et celles-ci continuent de comporter pour le membre visiteur, le logo de téléchargement. Peux-tu envisager une extension de ce paramètre aux vidéos (Ma galerie en comporte déjà plus d'une cinquantaine) ? Ta galerie en mode V3 est vraiment un outil formidable, j'en suis à ma deuxième; la première cependant est restée en V2 pour certaines fonctionalités non reportées en V3  Une troisième est déjà dans les cartons :-)
Bonne soirée.

#16 Utilisation » Téléchargement photos (album ou individuelles) par Invité » 28-11-2020 09:52:25

Denis GIRAULT
Réponses : 4

Bonjour David,
J'ai créé un Membre Visiteur dans ma galerie de Type (Groupe) Invité. J'ai restreint dans fonctionnalité ses possibilités en particulier le téléchargement d'album photos. Malgré cela je constate qu'il peut cependant télécharger les photos (une à une) ce qui revient, s'il est décidé et persévérant, à réaliser ce qui lui était interdit par l'administrateur : récupérer un album photo complet. Pourrait-on lier administrativement ces 2 fonctionnalités qui se rejoignent  (téléchargement album complet et téléchargement photo individuelle) ? Merci pour ta réponse.

#17 Utilisation » Exit fonctions retouche d'une photo ? » 19-11-2020 14:22:56

Denis GIRAULT
Réponses : 1

Bonjour. Je n'ai pas retrouvé les fonctions de retouche de la V2 (administration photo).
En particulier la rotation 90° très utile dans certains cas de mauvaise prise de photo.
Le rognage était également très utile pour rectifier des cadrages mal assurés.
Y aura-t-il un espoir de les retrouver en V3 ? Merci d'avance pour votre réponse.

#19 Re : Bugs » [RESOLU] Verrouillage album inopérant » 13-05-2020 11:48:51

Cette notion de visibilité différente d'un navigateur à l'autre continue de me perturber mais forcément tu as raison. Peut-être ai-je joué à tort avec le paramètre "rester connecté" sans trop comprendre son intérêt exact au niveau d'une procédure de mot de passe ? Je passe ce (faux) problème en Résolu car ayant recommencé pour la nième fois sur Edge le transfert de mon album et la déclaration aussitôt d'un verrouillage par mot de passe celui-ci s'est bien affiché cette fois avec un cadenas. J'ai dû faire un mauvais rêve ;-)
Bonne journée.

#20 Re : Bugs » [RESOLU] Verrouillage album inopérant » 12-05-2020 20:47:18

Je viens de cerner un peu plus le problème . Mon PC est sur Windows 10 (V1903) J'utilise principalement Edge
Mais cette fois par hasard j'ai utilisé Chrome et curieusement c'est là que j'ai vu mon problème se dévoiler  :

1) Accès à ma galerie V3 avec Chrome

http://photos78.fr/testV3/CadenasG.JPG

Tout est OK l'album est verrouillé. Je laisse tel que et je change de navigateur.

2) Accés à ma galerie V3 avec Edge :

http://photos78.fr/testV3/CadenasE.JPG

et là mon album callac apparait déverrouillé (accès total) alors que JE N'AI RIEN FAIT sur l'album après 1)

3) Curieux, j'ai poussé l'expérience avec Firefox même visibilité qu'avec Chrome (Album réapparait verrouillé)

J'en déduis que tu n'utilises pas Edge sinon tu aurais vu mon problème depuis le début. ;-))

Bonne soirée.
PS: Je ne touche à rien sur ma galerie V3 pour que tu puisses constater.

#21 Re : Bugs » [RESOLU] Verrouillage album inopérant » 12-05-2020 11:15:49

Salut David,
Je t'ai envoyé par mail les URL de mes 2 sites celui en V2 et celui en V3 où la différence de comportement suite au verrouillage d'un album apparait.
@+

#22 Re : Bugs » [RESOLU] Verrouillage album inopérant » 11-05-2020 11:04:50

Désolé David j'insiste, comme précisé dans mes précédents posts et images
j'ai suivi STRICTEMENT ce que tu expliques dans ta doc pour verrouiller mon album "Callac":

http://photos78.fr/testV3/Cadenas5.JPG

Et TOUT DE SUITE APRES, en passant en mode invité / non connecté,  et SANS RIEN FAIRE d'AUTRE, sur  ma galerie  je n'obtiens pas l'apparence d'un album verrouillé mais celui d'un album
"Callac" avec un icone de cadenas déverrrouillé et donc avec un accès pour tout utilisateur.

http://photos78.fr/testV3/Cadenas1.JPG

Comment tu expliques cela?
Merci

#23 Re : Bugs » [RESOLU] Verrouillage album inopérant » 10-05-2020 22:33:07

Je reprends le cheminement complet et CHRONOLOGIQUE de mon premier message qui montre bien une différence de comportement entre la V2 et la V3 au niveau du verrouillage d'un album.

Effectivement je venais de verrouiller cet album en lui assignant en tant qu'admin, un mot de passe  (voir image 1) C'est bien comme cela qu'on décide de verrouiller un album en V3 ??? En tout cas c'est comme ça en V2 et ça marche !!!
Donc dans les deux écrans suivants après être passé en mode non connecté (Invité) j'aurais dû avoir une vignette avec un cadenas et une demande de mot de passe pour pouvoir ouvrir cet album. Dans la même configuration et le même déroulement, ce fut le cas avec iGalerie V2  Mais en V3 (voir les images 2 et 3) je n'ai  pas eu de vignette iconé cadenas mais la vignette normale de l'album avec le cadenas ouvert et  l'invité a pu accéder à toutes les photos d'un album non verouillé.

C'est cette phase qui me fait dire que cela ne fonctionne pas et que le verrouillage au sens strict d'un album est ineffectif en V3 (du moins au premier coup).
Merci d'avance pour ta réponse.

#24 Re : Bugs » [RESOLU] Verrouillage album inopérant » 10-05-2020 17:56:11

Re,
j'ai fait ce que tu as dit : en cliquant sur l'icone de cadenas fermé : j'ai obtenu la page suivante :

http://photos78.fr/testV3/Cadenas3.JPG

dans lequel j' ai rentré le mot de passe fourni précédemment
Et j'ai décoché l'item "rester connecté" (dans les 2 cas c'est pareil) --> Valider
Retour à la galerie rien de changé, le cadenas est toujours ouvert au niveau de la vignette, tout est accessible.
Je me déconnecte de super admin pour repasser en mode non connecté rien non plus n'a changé cet album reste accessible quoiqu'on fasse (Arrêt accès galerie et relance).
Peut-être je manipe mal, dans ce cas merci à toi de m'expliquer comment fait-on pour verrouiller et déverrouiller un album ? C'était simple en V2 et je le faisais marcher sans problème. Là s'il n'y a pas de bug j'y perds mon latin.
Merci d'avance.

#25 Bugs » [RESOLU] Verrouillage album inopérant » 10-05-2020 14:06:12

Denis GIRAULT
Réponses : 12

Dernière version de iGalerie V3 de Mai

J'ai télechargé un album de photos callac par ftp sur le site et ensuite déclaré en accès verrouillé (par mot de passe) :

http://www.photos78.fr/testV3/Cadenas1b.JPG

J'accède ensuite à la galerie en mode non connecté : je peux visualisr la vignette de cet album :

http://www.photos78.fr/testV3/Cadenas1.JPG


Et en cliquant sur cette vignette j'accède à toutes les vignettes des photos qu'il contient (toujours sans aucun mot de passe demandé)

http://www.photos78.fr/testV3/Cadenas2.JPG

Et au final je peux même afficher chacune des photos de cet album.
Bref aucun verouillage effectif.

Test fait de la même manière sur la V2 --> tout est OK
La vignette de l'album est bien un cadenas et un clic dessus provoque la demande du mot de passe.

Pied de page des forums

Propulsé par FluxBB