iGalerie

Vous n'êtes pas identifié(e).

#1 Re : Installation » Erreur Serveur 500 lors de l'upgrade 2.4.13 > 3 » 26-03-2020 10:07:19

Bonjour David, la version V3 fonctionne très bien, je confirme (./galerie3/index.php sur mon site) mais j'ai plus de 12.000 photos et commentaires sur ma V2 !!! j'étudie la solution de convertir ma base de données SQL vers SQLite. As tu des solutions ? bonne journée, Cordialement

#2 Re : Discussions » iGalerie 3.0 » 03-02-2020 11:11:10

Bonjour David, je ne trouve pas l'option COPYRIGHT "sur la photo" comme dans la V2 ! ai-je mal cherché ou n'est-elle pas présente ? Si c'est le cas, est-elle prévue ? Bonne journée, Pierre-Yves (en test dans mon dossier /galerie3)

#3 Re : Discussions » iGalerie 3.0 » 17-01-2020 17:24:43

Bonjour David et encore merci pour tout ce travail ! Ma question est simple et un peu naïve, mais peut-on installer (pour tester) sur le même site, où fonctionne déjà la V2, la V3 sans risque de dysfonctionnement entre les deux ? J'ai peur de mettre le bazar dans la V2 ! (Je n'ai pas vu si la question a déjà été posée!)
Cordialement, Pierre-Yves

#4 Re : Bugs » Descriptions des images absentes après migration V1 vers V2 » 05-04-2019 12:32:36

Je viens de trouver tout seul ! problème avec le navigateur internet (Chrome) et les cookies. J'ai vidé le cache, l'historique et tout le reste... et me suis reconnecté à l'administration et ça fonctionne. Je voulais le préciser, si d'autres utilisateurs ont le même problème. Bonne journée smile

#5 Re : Bugs » Descriptions des images absentes après migration V1 vers V2 » 05-04-2019 12:23:36

Bonjour David, Super maintenant tout fonctionne depuis hier, enfin presque !!! Un seul souci ce matin, j'ai créé un nouveau dossier et téléchargé des photos en FTP. Mais lorsque que je retourne sur l'interface d'administration je ne peux pas cliquer sur AJOUT d'IMAGES ! Je reste sur l'écran TABLEAU DE BORD !
http://www.igalerie.org/forum/viewtopic.php?id=2957 J'ai touvé cette discussion sur le site mais je ne vois pas la réponse à la solution.

#6 Re : Bugs » Descriptions des images absentes après migration V1 vers V2 » 04-04-2019 22:57:41

Bonsoir David et et un grand merci pour toutes les réponses que tu m'as envoyées à chaque question. J'utilisais depuis 2006 l'ancienne version et je redoutais de tout perdre en passant à la nouvelle version. Je suis très heureux d'avoir enfin réussi après plusieurs essais et de pouvoir maintenant écrire normalement les lettres avec les accents, et d'avoir en prime la fonction canonical dans les balises etc... j'avais tout téléchargé mais n'avais pas réalisé tout dans le bon ordre, c'est ton dernier message avec le mot APRES en majuscules qui m'a ouvert les yeux !!! comment te remercier ? je mettrai un mot sur mon site wink Je te félicite encore pour la qualité de la galerie BRAVO

#7 Re : Bugs » Descriptions des images absentes après migration V1 vers V2 » 04-04-2019 19:00:57

Merci encore et à nouveau David, je pense que c'est bon puisque dans la base de données les descriptions sont apparement toutes présentes
Dernier souci, je n'arrive plus à me loguer sur l'admin, mot de passe incorrect.J'ai recu un mail et réinitialisé le mot de passe, mais j'ai un message : Brute force attack detected
J'y suis presque !!!

#8 Re : Bugs » Descriptions des images absentes après migration V1 vers V2 » 04-04-2019 17:11:46

Toujours le message erreur 239 unable to connect to the database en exécutant le script à l'instant, je me suis arêté à ce stade sans exécuter la suite de l'installation.

#9 Re : Bugs » Descriptions des images absentes après migration V1 vers V2 » 04-04-2019 17:03:24

Oui exactement, j'ai réalisé un scan après chaque installation, car la première fois les photos étaient apparues uniquement apres le scan des dossiers.

Je pense avoir exécuté le script migration_igalerie1 correctement, je l'ai mis à la racine de la /galerie/migration_igalerie1.php et exécuté dans le navigateur tout simplement.

Si j'ai bien compris, les coordonnées de la base de donnée sont dans configv1.php, apparement ils sont corrects. je réééessaie maintenant

#10 Re : Bugs » Descriptions des images absentes après migration V1 vers V2 » 04-04-2019 15:33:41

le deuxième message d'erreur :

iGalerie
FTP

Ajout d'images
OBJETS

Albums
Commentaires
Votes
Tags
Appareils photos
Utilisateurs
RÉGLAGES

Pages
Widgets
Fonctionnalités
Options
Thèmes
Maintenance
INFORMATIONS

Galerie
Activité
Système
Incidents
Tableau de bord déconnexion | voir la galerie
Connecté : Pierre-Yves
Incidents
incidents [5]

tout sélectionner - inverser la sélection format forum
#    5    détails   
Date    2019-04-04 12:26:03
Version    2.4.11
Type    DB_ERROR
Fichier    includes/classes/db.class.php
Ligne    218
Page    ftp
Message   
SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry 'Rallycross_de_Kerlabo_2017/Kerlabo-2017--PYA29387.jpg' for key 'igal2_uk1_images'
#    4    détails   
Date    2019-04-04 12:25:56
Version    2.4.11
Type    DB_ERROR
Fichier    includes/classes/db.class.php
Ligne    218
Page    ftp
Message   
SQLSTATE[40001]: Serialization failure: 1213 Deadlock found when trying to get lock; try restarting transaction
#    3    détails   
Date    2019-04-04 12:24:40
Version    2.4.11
Type    DB_ERROR
Fichier    includes/classes/db.class.php
Ligne    218
Page    ftp
Message   
SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry 'Rallycross_de_Loheac_2017/LoheacRX-Rallycross-2017-PA32205.jpg' for key 'igal2_uk1_images'
#    2    détails   
Date    2019-04-04 12:22:08
Version    2.4.11
Type    DB_ERROR
Fichier    includes/classes/db.class.php
Ligne    218
Page    ftp
Message   
SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry 'Rally-Pays-Loheac-2016/Vincent-HUMEAU-Yoan-VERNAGEAU-PA15722.jpg' for key 'igal2_uk1_images'
Détails   
Array
(
    [_code] => 23000
    [trace] => Array
        (
            [0] => includes/classes/db.class.php line 218:
PDOStatement->execute(array (
  'cat_id' => 1,
  'user_id' => 1,
  'image_path' => 'Rally-Pays-Loheac-2016/Vincent-HUMEAU-Yoan-VERNAGEAU-PA15722.jpg',
  'image_url' => 'rallye-du-pays-de-loheac-2016',
  'image_height' => 800,
  'image_width' => 1200,
  'image_filesize' => 221860,
  'image_exif' => NULL,
  'image_iptc' => NULL,
  'image_xmp' => NULL,
  'image_rotation' => 1,
  'image_lat' => NULL,
  'image_long' => NULL,
  'image_name' => 'Rallye du Pays de Lohéac 2016',
  'image_desc' => 'Photo prise lors du Rallye du Pays de Lohéac, pendant les épreuves du dimanches 3 Avril 2016 sur les communes de Lieuron et Lohéac',
  'image_adddt' => '2019-04-04 12:19:39',
  'image_crtdt' => '2016-04-03 16:31:35',
  'image_status' => 1,
))

            [1] => includes/classes/upload.class.php line 1563:
db->exec(array (
  0 =>
  array (
    'sql' => 'INSERT INTO igal2_images (
            cat_id, user_id, image_path, image_url, image_height, image_width,
            image_filesize, image_exif, image_iptc, image_xmp, image_rotation,
            image_name, image_desc, image_adddt, image_crtdt, image_lat,
            image_long, image_status)
            VALUES (:cat_id, :user_id, :image_path, :image_url, :image_height,
            :image_width, :image_filesize, :image_exif, :image_iptc, :image_xmp,
            :image_rotation, :image_name, :image_desc,
            :image_adddt, :image_crtdt, :image_lat, :image_long, :image_status)',
    'params' =>
    array (
      0 =>
      array (
        'cat_id' => 1,
        'user_id' => 1,
        'image_path' => 'Rally-Pays-Loheac-2016/Vincent-HUMEAU-Yoan-VERNAGEAU-PA15722.jpg',
        'image_url' => 'rallye-du-pays-de-loheac-2016',
        'image_height' => 800,
        'image_width' => 1200,
        ...)

            [2] => includes/classes/upload.class.php line 647:
upload->_updateDB(array (
  'a_albums' => 25,
  'd_albums' => 0,
  'a_images' => 4452,
  'd_images' => 0,
  'a_size' => 1567318301,
  'd_size' => 0,
))

            [3] => admin/index.php line 12015:
upload->getAlbums()

            [4] => admin/index.php line 861:
ftp::scan()

        )

    [additional] => Array
        (
            [sql] => Array
                (
                    [0] => Array
                        (
                            [sql] => INSERT INTO igal2_images (
            cat_id, user_id, image_path, image_url, image_height, image_width,
            image_filesize, image_exif, image_iptc, image_xmp, image_rotation,
            image_name, image_desc, image_adddt, image_crtdt, image_lat,
            image_long, image_status)
            VALUES (:cat_id, :user_id, :image_path, :image_url, :image_height,
            :image_width, :image_filesize, :image_exif, :image_iptc, :image_xmp,
            :image_rotation, :image_name, :image_desc,
            :image_adddt, :image_crtdt, :image_lat, :image_long, :image_status)
                            [params] => Array
                                (
                                    [0] => Array
                                        (
                                            [cat_id] => 1
                                            [user_id] => 1
                                            [image_path] => Rally-Pays-Loheac-2016/Vincent-HUMEAU-Yoan-VERNAGEAU-PA15722.jpg
                                            [image_url] => rallye-du-pays-de-loheac-2016
                                            [image_height] => 800
                                            [image_width] => 1200
                                            [image_filesize] => 221860
                                            [image_exif] =>
                                            [image_iptc] =>
                                            [image_xmp] =>
                                            [image_rotation] => 1
                                            [image_lat] =>
                                            [image_long] =>
                                            [image_name] => Rallye du Pays de Lohéac 2016
                                            [image_desc] => Photo prise lors du Rallye du Pays de Lohéac, pendant les épreuves du dimanches 3 Avril 2016 sur les communes de Lieuron et Lohéac
                                            [image_adddt] => 2019-04-04 12:19:39
                                            [image_crtdt] => 2016-04-03 16:31:35
                                            [image_status] => 1
                                        )

                                    [1] => Array
                                        (
                                            [cat_id] => 1
                                            [user_id] => 1
                                            [image_path] => Rally-Pays-Loheac-2016/Sebastien-BRET-Julia-OBRIEN-PA15682.jpg
                                            [image_url] => rallye-du-pays-de-loheac-2016
                                            [image_height] => 800
                                            [image_width] => 1200
                                            [image_filesize] => 233596
                                            [image_exif] =>
                                            [image_iptc] =>
                                            [image_xmp] =>
                                            [image_rotation] => 1
                                            [image_lat] =>
                                            [image_long] =>
                                            [image_name] => Rallye du Pays de Lohéac 2016
                                            [image_desc] => Photo prise lors du Rallye du Pays de Lohéac, pendant les épreuves du dimanches 3 Avril 2016 sur les communes de Lieuron et Lohéac
                                            [image_adddt] => 2019-04-04 12:19:39
                                            [image_crtdt] => 2016-04-03 16:16:26
                                            [image_status] => 1
                                        )

************************************************************************
etc...... jusqu'à l'image numéro 4451 / soit plus de 98000 lignes
fin du message :
************************************************************************
                      )

                )

            [params] =>
        )

)
#    1    détails   
Date    2019-04-04 12:09:05
Version    2.4.11
Type    DB_ERROR
Fichier    includes/classes/db.class.php
Ligne    133
Page   
Message   
invalid data source name
Pour la sélection :   


propulsé par iGalerie

#11 Re : Bugs » Descriptions des images absentes après migration V1 vers V2 » 04-04-2019 15:18:52

Array
(
    [_code] => 0
    [trace] => Array
        (
            [0] => includes/classes/db.class.php line 133:
PDO->__construct('*****', '*****', '*****')

            [1] => migration_igalerie1.php line 236:
db->__construct()

            [2] => migration_igalerie1.php line 21:
migration::init()

        )

    [additional] => Array
        (
            [sql] =>
            [params] =>
        )

)

#12 Re : Bugs » Descriptions des images absentes après migration V1 vers V2 » 04-04-2019 15:17:00

Merci David pour la rapidité de ta réponse. Je pense avoir lu plusieurs fois la procédure et ne vois pas où je n'ai pas pas fait ce qu'il fallait. J'ai bien tout effacé sur le serveur dans iGalerie1 / sauf config renommé en configv1 et le dossier albums. Je vais t'envoyer le message incident 1 en premier.

#13 Re : Bugs » Descriptions des images absentes après migration V1 vers V2 » 04-04-2019 12:48:49

Bonjour David, j'ai passé la matinée à réinstaller complètement ma galerie. toujours le même problème des descriptions non mises à jour. (j'ai tout noté cette fois!) à l'exécution du script (migration_igalerie1.php) j'ai eu un message d'erreur : 239 unable to connect to the database.
J'ai pu me connecter quand même à l'admin et continuer la procédure d'installation qui s'est parfaitement déroulée. A part les descriptions tout fonctionne, etj'ai 5 incidents.

5 - DB_ERROR : SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry 'Rallycross_de_Kerlabo_2017/Kerlabo-2017--PYA29387.jpg' for key 'igal2_uk1_images'

4 - DB_ERROR : SQLSTATE[40001]: Serialization failure: 1213 Deadlock found when trying to get lock; try restarting transaction

3 - DB_ERROR : SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry 'Rallycross_de_Loheac_2017/LoheacRX-Rallycross-2017-PA32205.jpg' for key 'igal2_uk1_images'

2 - DB_ERROR : SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry 'Rally-Pays-Loheac-2016/Vincent-HUMEAU-Yoan-VERNAGEAU-PA15722.jpg' for key 'igal2_uk1_images'

1 - DB_ERROR : invalid data source name

Je peux te retourner les messages intégralement si besoin.
Merci encore

#14 Re : Bugs » Descriptions des images absentes après migration V1 vers V2 » 02-04-2019 16:14:48

Pour la version de PHP je te confirme être en 5.6 - Pour les modifications, elles sont uniquement au niveau du look pour être aux couleurs de mon site, donc uniquement des modifications au niveau des CSS et quelques balises meta et un script json ajoutés dans la partie head pour google. Tout ceci après l'installation qui avait déjà le problème des description absentes. Le script migration c'est bien passé mais ce n'était pas très clair. Petit bug pour revenir sur la page d'installation, qui s'est ensuite bien déroulé, tous les voyant étaient au vert. J'étais sur la version igalerie 1.0.7 et la version installée est la dernière 2.4.11
Penses-tu qu'il serait plus simple de réinstaller la galerie ? ou penses-tu avoir une solution en gardant celle-ci ? Vais-je risquer de rencontrer le même problème si je réinstalle ? Quelle solution me conseilles-tu ?

#15 Re : Bugs » Descriptions des images absentes après migration V1 vers V2 » 02-04-2019 13:03:17

Bonjour David, pour apporter plus d'informations, je te confirme avoir eu des soucis avec OVH au moment de l'installation. Lorsque je scannais les dossiers, la procédure était très longue, et le serveur renvoyait une page d'erreur 504. J'ai dû refaire de nombreuses fois la procédure.
S'il le faut, j'envisage de tout effacer (sauf confv1.php) et de tout réinstaller. J'ai maintenant toutes les sauvegardes des fichiers, cela devrait être rapide. Sauf si tu as une autre idée, et d'autres conseils avant de refaire la procédure d'installation. Merci encore !

#16 Re : Bugs » Descriptions des images absentes après migration V1 vers V2 » 02-04-2019 01:51:53

Bonsoir David et merci pour ta réponse. J'ai actuellement une erreur :

# : 1
Date : 2019-04-01 23:42:46
Version : 2.4.11
Type : PHP_PARSE
Fichier : template/default/index.tpl.php
Ligne : 127
Page : album/29-rallycross-de-loheac-2018
Message : syntax error, unexpected 'endif' (T_ENDIF)
Détails :
Array
(
)

#17 Bugs » Descriptions des images absentes après migration V1 vers V2 » 01-04-2019 07:06:31

PYACESSON
Réponses : 18

Bonjour David, j'ai réinstallé la version 2 (en recommençant deux deux fois). Le seul problème est que je n'ai pas récupéré les descriptions des images. Ma Galerie comporte 58 albums et plus de 10.000 images ! j'ai regardé du côté de la base de données, mais je bloque ! pour info, je suis hébergé chez OVH.

Précision : Je retrouve bien les descriptions des images dans Mysql :
1: dans : igal_images/image _description (Version 1)
2 :Et aussi dans : igal2_images/image_desc (dans Version 2)
En revanche, sur le site, une seule galerie (la numéro 34) affiche les descriptions igalerie
alors qu'elles sont bien présentes dans dans la base SQL.

Y a t-il une solution sans réinstaller une troisième fois ? Merci d'avance, cordialement, Pierre-Yves

Pied de page des forums

Propulsé par FluxBB