iGalerie

#1 06-02-2012 11:27:56

David
Développeur d'iGalerie
Inscription : 12-05-2006
Messages : 3 831
Site Web

Anglais (en_GB)

Description

- Auteur : rolandm
- Date : 6 février 2012
- Dernière mise à jour : 21 février 2012
- Compatibilité iGalerie : iGalerie 2.1.x


Téléchargement

Cliquez ici


Comment installer une langue ?

Pour installer une nouvelle langue, il faut copier-coller le contenu d'une archive de langue dans le répertoire d'iGalerie, puis installer la langue dans la partie "langues" de la section Options / Galerie de l'interface d'administration.


Pour toute demande de corrections/améliorations, n'hésitez pas à répondre à ce sujet.

Dernière modification par David (21-02-2012 10:42:36)

Hors ligne

#2 20-02-2012 01:45:17

rolandm
Nouveau membre
Inscription : 04-02-2012
Messages : 5

Re : Anglais (en_GB)

J'ai relevé quelques erreurs dans le fichier "locale/en_GB/igalerie.php".
- ligne 35 doit figurer comme suit: ["%s Go"] = "%s Gb";
- ligne 58 doit figurer comme suit: ["%s Ko"] = "%s Kb";
- ligne 61 doit figurer comme suit: ["%s Mo"] = "%s Mb";
- ligne 67 doit figurer comme suit: ["%s octet"] = "%s byte";
- ligne 68 doit figurer comme suit: ["%s octets"] = "%s bytes";
- ligne 72 doit figurer comme suit: ["%s To"] = "%s Tb";

Ces modifications permettent l'affichage du poids des images qui n'apparaissait pas.

I have found a few errors in the file "locale/en_GB/igalerie.php".

- line 35 should read: ["%s Go"] = "%s Gb";
- line 58 should read: ["%s Ko"] = "%s Kb";
- line 61 should read: ["%s Mo"] = "%s Mb";
- line 67 should read: ["%s octet"] = "%s byte";
- line 68 should read: ["%s octets"] = "%s bytes";
- line 72 should read: ["%s To"] = "%s Tb";

These modifications will display the weight of the images properly

rolandm

Hors ligne

#3 20-02-2012 11:39:18

David
Développeur d'iGalerie
Inscription : 12-05-2006
Messages : 3 831
Site Web

Re : Anglais (en_GB)

Merci pour ces corrections, je viens de mettre à jour l'archive.
J'en ai également profité pour faire quelques autres corrections/changements :

ligne 2 : "" => "%A, %B %d, %Y at %H:%M:%S"
ligne 3 : "" => "%A, %B %d, %Y"
ligne 6 : "" => "%B %d, %Y"
ligne 8 : "" => "%s:"
ligne 60 : "%s menbers" => "%s members"
ligne 80 : "%s Kb and %s pixels per side maximum" => "(%s Kb and %s pixels per side maximum)"
ligne 82 : "" => "."
ligne 119 : "Enable album uploading" => "Enable album downloading"
ligne 123 : "Enable RSS flow" => "Enable RSS feeds" (j'ai remplacé le mot "flow" par "feed" ailleurs aussi)
lignes 352-355 (et ailleurs) : "E-mail message" => "E-mail"
ligne 396-397 : "disconnection" => "logout"
lignes 958-959 : "Name of the directory" => "Directory name"
ligne 960 : "Name of the group" => "Group name"
ligne 984 : "Number of favoritse :" => "Number of favorites:"
lignes 1176-1178 : "Re size" => "Resize"

J'ai aussi remplacé partout le verbe "enroll" par "register" qui est plus approprié il me semble.

Par ailleurs, l'utilisation des deux-points diffère entre le français et l'anglais (présence ou non d'une espace avant les deux-points) :

http://www.la-ponctuation.com/deux-points.html a écrit :

Règles typographiques

En français : texte[espace]:[espace]texte
En anglais : texte:[espace]texte

Enfin, le séparateur décimal diffère également entre le français et l'anglais : virgule (,) pour le français et point (.) pour l'anglais. D'où la ligne 82 du fichier de langue.

Hors ligne

#4 22-02-2012 22:23:34

Mr.Mechant
Membre
Inscription : 11-10-2011
Messages : 36

Re : Anglais (en_GB)

Merci à toi rolandm, et merci David pour les petites corrections wink

Hors ligne

#5 23-02-2012 08:55:49

rolandm
Nouveau membre
Inscription : 04-02-2012
Messages : 5

Re : Anglais (en_GB)

Merci David pour la mise a jour ainsi que  pour tes modifications personnelles.

Hors ligne

#6 28-10-2013 18:33:44

yvand
Nouveau membre
Inscription : 28-10-2013
Messages : 3

Re : Anglais (en_GB)

Bonjour,

J'ai la version 2.2.6 et j'ai fait exactement ce qu'il y a marqué en mettant le fichier GB mais dans l'administration de igalerie j'ai toujours pas l'anglais en langues disponibles.

Y a til autre chose à faire

Merci d'avance

Hors ligne

#7 29-10-2013 20:42:02

David
Développeur d'iGalerie
Inscription : 12-05-2006
Messages : 3 831
Site Web

Re : Anglais (en_GB)

Salut,

Tu dois aussi installer la langue dans les options (section Options / Galerie, puis Langues).

Hors ligne

#8 29-10-2013 22:14:24

yvand
Nouveau membre
Inscription : 28-10-2013
Messages : 3

Re : Anglais (en_GB)

Oui mais dans options/galerie il n'y a pas la langue qui apparait. comment faire?

Hors ligne

#9 27-11-2013 16:23:58

yvand
Nouveau membre
Inscription : 28-10-2013
Messages : 3

Re : Anglais (en_GB)

Bonjour,

Je n'arrive toujours pas à mettre la langue anglaise.
Voici ce que j'ai fait :
- téléchargé le fichier en_GB.zip
- je l'ai décompressé pour le mettre dans le dossier locale d'igalerie
- j'ai mis l'image du drapeau en png dans images
- et quand je vais dans Options / Galerie, puis Langues, je n'ai rien dans la partie langues disponibles.

Merci de m'aider..

Hors ligne

#10 28-11-2013 22:06:33

David
Développeur d'iGalerie
Inscription : 12-05-2006
Messages : 3 831
Site Web

Re : Anglais (en_GB)

Tu as bien mis le répertoire "en_GB" dans le répertoire "locale", avec  "fr_FR" ?

Hors ligne

#11 29-11-2013 12:19:52

jplemoine
Membre
Lieu : Charbonnières-les-Bains
Inscription : 24-06-2007
Messages : 49
Site Web

Re : Anglais (en_GB)

J'ai essayé :
le téléchargement une fois décompressé donne un répertoire en_GB qui a 2 sous-répertoires :
- images : mettre le contenu dans images du site
- locale : mettre le contenu dans locale du site
Attention : il y a dans locale, un répertoire en-GB mais c'est pas le même qu'au début.
Il faut mettre la même arborescence que pour la langue FR.

Hors ligne

#12 21-01-2019 20:16:58

kastor
Membre
Inscription : 30-01-2014
Messages : 19

Re : Anglais (en_GB)

Salut, je déterre le post car je cherchais l'info sur comment changer de langue, et je suis finalement tombé ici... Même problème, la langue additionnelle n'apparaît pas dans le menu d'installation de la galerie (options) --> solution: Vérifier les droits d'accès aux fichiers (775) et enjoy.
ça pourra servir peut-être à d'autres même si je suis pas sûr de trouver des versions compatibles avec la nouvelle version.

Message   
include(/locale/en_GB/lang.php): failed to open stream: Permission denieds

Dernière modification par kastor (21-01-2019 20:28:36)

Hors ligne

Pied de page des forums