iGalerie

Vous n'êtes pas identifié(e).

Annonce

Version en développement : iGalerie 3.0

#1 15-05-2013 10:29:51

mercyril
Membre
Inscription : 14-10-2012
Messages : 10
Site Web

[DL] Modification du thème principal

Bonjour,

Voici mon site pour lequel j'ai modifié le thème principal proposé par défaut (dark).

Baladez vous sur les photos pour voir les effets.

http://photo.mercyril.fr

Lien de téléchargement : Ici

Ce thème est compatible avec les versions 2.3.4 à 2.4.2 d'iGalerie.

Ken@vo

Dernière modification par mercyril (21-01-2016 18:53:36)

Hors ligne

#2 28-06-2013 12:55:02

Christian
Membre
Lieu : Belgique
Inscription : 16-06-2010
Messages : 292
Site Web

Re : [DL] Modification du thème principal

Pas mal du tout !
Bravo cela rend fort bien.

Christian

Hors ligne

#3 30-06-2013 11:23:22

mercyril
Membre
Inscription : 14-10-2012
Messages : 10
Site Web

Re : [DL] Modification du thème principal

Merci beaucoup ;o)

Hors ligne

#4 04-01-2014 11:45:33

MBPhoto91
Membre
Inscription : 27-04-2012
Messages : 20

Re : [DL] Modification du thème principal

Superbe thème
Pourrais tu le rendre disponible au téléchargement afin de le partager auprès de la communauté iGalerie ?

Michel

Hors ligne

#5 01-06-2014 11:41:59

mercyril
Membre
Inscription : 14-10-2012
Messages : 10
Site Web

Re : [DL] Modification du thème principal

J'ai ajouté un lien pour le télécharger.

Have fun !!!

Dernière modification par mercyril (01-06-2014 11:42:26)

Hors ligne

#6 14-05-2015 16:56:15

darkatis
Membre
Inscription : 29-04-2015
Messages : 12

Re : [DL] Modification du thème principal

super, par contre, y a le meme bug que dans le theme par defaut : dans l'upload d'image de chaque utilisateur, la liste des albums est systematiquement par ID et non par cat_name , ce qui pose des pb quand on a un grand nombre d'albums, car ils sont pas dans l'ordre alphabetique du coup.

j'insiste bien : uniquement dans les menus deroulants du choix des albums pour la partie UPLOAD D'IMAGE d'un utilisateur .

si tu as une idee pour corriger ca, je suis preneur

Hors ligne

#7 04-06-2015 10:44:36

mercyril
Membre
Inscription : 14-10-2012
Messages : 10
Site Web

Re : [DL] Modification du thème principal

Je n'ai pas d'idée pour ton soucis
Je n'ai fais que de léger changement par rapport au thème par défaut
Bon courage pour ton soucis

Hors ligne

#8 18-08-2015 10:33:46

mercyril
Membre
Inscription : 14-10-2012
Messages : 10
Site Web

Re : [DL] Modification du thème principal

Test avec la version 2.3.6 igalerie ok

Hors ligne

#9 21-01-2016 18:54:04

mercyril
Membre
Inscription : 14-10-2012
Messages : 10
Site Web

Re : [DL] Modification du thème principal

Test avec la version 2.4.2 igalerie ok

Hors ligne

#10 30-01-2016 14:34:16

MissAnna123
Membre
Inscription : 11-03-2014
Messages : 20

Re : [DL] Modification du thème principal

bonjour,
Si vous avez une possibilité pour rendre responsive votre thème, n'hésitez pas smile cela aiderait beaucoup de monde smile
Merci à vous.

Hors ligne

#11 20-01-2019 21:04:01

kastor
Membre
Inscription : 30-01-2014
Messages : 19

Re : [DL] Modification du thème principal

Bonjour, pouvez-vous mettre à jour le lien pour télécharger le thème? Merci beaucoup

Hors ligne

#12 09-01-2020 19:44:22

ym_trainz
Membre
Inscription : 11-03-2018
Messages : 1

Re : [DL] Modification du thème principal

Bonsoir,
Merci pour votre exemple.
J'ai réussi, en modifiant également le thème principal (à mon humble niveau) à le rendre responsive le thème, notamment sur mon "vieux" téléphone. Vous pouvez jeter un oeil sur cette galerie si cela vous chante :

carlitoybanditos(point)com/igale/

Les modifs apportées au thème "default" sont ci-dessous.
J'espère que cela pourra être utile à quelqu'un ;-)
Cordialement,
Yves

-------------------------------------


\igale\template\default\index.tpl.php
ligne 21 avant <header>

<a href="http://www.carlitoybanditos.com/"><img src="../img/boutons/ico_home.png" height="28px" alt="ico_home.png" /></a>
-------------------------------------------
\igale\template\default\head.tpl.php
ligne 10

<meta name="viewport" content="width=device-width, initial-scale=1">
-------------------------------------------
\igale\template\default\style\dark\dark.css
ligne 15

html {
    font-size: 65%;

ligne 43

#igalerie {
    width: 96%;
    /* max-width: 860px; */
    /* min-width: 948px;
    max-width: 1200px; */
    margin: 0 auto;
    padding: 15px 10px;
    text-align: left;
    color: white;
}

ligne 230
#lang_change {
    ...
    height: 14px;
-------------------------------------------
\igale\template\default\image.tpl.php
ligne 109

<span style="width:<?php echo $tpl->getImage('width'); ?>px;" id="image_resize_msg">

    <span><?php echo __('Cliquez sur l\'image pour l\'afficher en taille réelle.'); ?
    </span>

</span>
remplacé px par % donc :
<span style="width:<?php echo $tpl->getImage('width'); ?>%;" id="image_resize_msg">

    <span><?php echo __('Cliquez sur l\'image pour l\'afficher en taille réelle.'); ?
    </span>

</span>

modif suite : ligne 110

            <span style="width:<?php echo $tpl->getImage('width'); ?>%;" id="image_resize_msg">
                <span>
                    <?php echo __('Cliquez sur l\'image pour l\'afficher en taille réelle.'); ?>
                </span>
            </span>

remplacé par
            <span>
                <?php echo __('Cliquez sur l\'image pour l\'afficher en taille réelle.'); ?>
            </span>

           

ligne 121 :

ajout de % dans
<img width="<?php echo $tpl->getImage('width'); ?>%"
height="<?php echo $tpl->getImage('height'); ?>%"
-------------------------------------------

Dernière modification par ym_trainz (11-01-2020 09:36:04)

Hors ligne

Pied de page des forums