iGalerie

Vous n'êtes pas identifié(e).

#1 18-11-2020 16:05:28

mmag
Membre
Lieu : Toul
Inscription : 15-08-2014
Messages : 20
Site Web

Blocage à l'installation

Bonjour.

J'ai déjà installé Igalerie3 sur mon localhost ou sur mon site depuis plusieurs mois sans problèmes.
J'essaie de relancer le logiciel dans une url nouvelle (changement de propriétaire).
Je n'arrive pas à joindre le serveur : HTTP Erreur 500.
J'ai Igalerie3.08 qui fonctionne normalement sur une url où cela a fonctionné normalement sous 3 versions de php : 7.2, 7.3, 7.4.
Autant une nouvelle implantation, donc une installation, qu'une sauvegarde de la galerie qui marche, ne veullent fonctionner.

Note : pour préparer le changement de propriétaire, j'ai fait au moins 4 ou 5 copies de sécurité de la sauvegarde de l'original qui doit être transféré par installation nouvelle ou par copie type back-up et je les ai fait fonctionner sous les 3 versions.

Voilà le message :
Cette page n’est pas disponible pour le moment
galerie.gpmt.fr ne peut actuellement pas traiter cette demande.
HTTP Erreur 500. 

J'ai vu dans la FAQ une réponse pour une erreur 500 en fin d'installation.
J'ai cette erreur à la validation de l'URL, je n'ai même pas l'apparition de la page d'installation.
Si je fait http://galerie.gpmt.fr ==> erreur 500.

Je suis en php 7.3 sur le provider  et 7.4 sur mon local. Mais, Igalerie a déjà fonctionné sur un php 7.2.
Le principal problème que je n'arrive même pas à atteindre le formulaire d'installation.

Malgré mes recherches, je ne vois pas pourquoi cela plante.
htaccess ? Autre ?

La galerie que je veux implanter fonctionne normalement sur http://galgpmt.mimagnier.fr/
(Chez le même hébergeur)

Auriez-vous une idée. Merci.

Michel

Dernière modification par mmag (19-11-2020 00:10:59)

Hors ligne

#2 20-11-2020 22:21:18

David
Développeur d'iGalerie
Inscription : 12-05-2006
Messages : 4 006
Site Web

Re : Blocage à l'installation

Salut,

Essayes en supprimant le fichier .htaccess. Et si ça ne marche toujours pas, regardes s'il y a des fichiers .xml dans le répertoire "errors".

Hors ligne

#3 20-11-2020 22:35:57

mmag
Membre
Lieu : Toul
Inscription : 15-08-2014
Messages : 20
Site Web

Re : Blocage à l'installation

J'ai déjà regardé. Ce qui m'inquiète, c'est que les mêmes logiciels fonctionnent parfaitement dans un autre domaine. Je suis en train de voir de ce côté là.

Je vais voir le répertoire errors.

Merci.

Hors ligne

#4 21-11-2020 22:23:53

mmag
Membre
Lieu : Toul
Inscription : 15-08-2014
Messages : 20
Site Web

Re : Blocage à l'installation

Bonsoir.

En fait, le problème est que j'avais modifié la version de php (qui était 5.4 pour Igalerie1), mais le changement n'était pas validé. C'est tout !

Mais, j'ai un autre problème : comment modifier le pass du super-administrateur ? Je l'ai en fonctionnement automatique, mais je n'arrive pas à le retrouver. Y-a-t-il un moyen ? Je n'y arrive pas avec l'accès au compte du super-admin et en modifiant les données dans la base.

J'ai utilisé la méthode proposée dans le forum avec le programme qui force la base de donnée. J'ai bien pu modifier le mot de passe.
En revanche, sur la copie type backup sur le domaine définitif, il n'y a pas moyen de faire fonctionner l'accès à l'administration. J'ai juste modifié dans le conf.php les données d'accès à la base qui ont changées.
Le petit module n'est pas compétent.
Le retour est une erreur 404 : pas le droit d'acces.

Est-ce que le CONF_KEY et le CONF_ACCESS_KEY peuvent intervenir si j'implante la galerie dans un autre domaine ?

Merci pour votre aide.
Cordialement.


Cordialement.

Dernière modification par mmag (22-11-2020 01:21:47)

Hors ligne

#5 22-11-2020 10:28:33

mmag
Membre
Lieu : Toul
Inscription : 15-08-2014
Messages : 20
Site Web

Re : Blocage à l'installation

Bonjour.

J'ai enfin réussi avec le petit programme cité dans le forum.
En fait, ce programme fonctionne seulement avec le id du super-utilisateur. Il ne change que le mot de passe. A tout le moins, c'est comme cela qu'il a marché.

Merci à ceux qui m'ont aidé.

Cordialement.

Hors ligne

Pied de page des forums