iGalerie

Vous n'êtes pas identifié(e).

#1 22-11-2020 18:24:05

gille.nicolas
Membre
Inscription : 22-11-2020
Messages : 8

Problème de migration V2 vers V3

Mon site http://perso.nicolasgf.be/igalerie a été upgradé à la dernière version 2.4.13 sans problème !
le fichier config/conf.php est renommé en config/confv2.php.
les répertoires d'iGalerie 2, albums, config et users sont sauvegardés
Je copie le contenu de l'archive d'iGalerie 3.0.8 dans le répertoire /var/www/html/
je remplace les 3 fichiers  albums, config et users.
ensuite chmod -R 777 /var/www/html/igalerie
Et localhost/igalerie répond:
Warning: Use of undefined constant CONF_DEBUG_MODE - assumed 'CONF_DEBUG_MODE' (this will throw an Error in a future version of PHP) in /var/www/html/igalerie/includes/core/ErrorHandler.class.php on line 147
Warning: Use of undefined constant CONF_DEBUG_MODE - assumed 'CONF_DEBUG_MODE' (this will throw an Error in a future version of PHP) in /var/www/html/igalerie/includes/core/ErrorHandler.class.php on line 318
Et pas possible d'aller plus loin ?
Pouvez-vous m'aider ?
Merci d'avance pour la bonne suite que vous réserverez à ma demande
Bien à Vous
Gille Nicolas

Hors ligne

#2 22-11-2020 21:28:11

David
Développeur d'iGalerie
Inscription : 12-05-2006
Messages : 4 158
Site Web

Re : Problème de migration V2 vers V3

Salut,

Le répertoire "config" contient-il les deux fichiers "confv2.php" et "conf.php" ?

Hors ligne

#3 22-11-2020 22:43:12

gille.nicolas
Membre
Inscription : 22-11-2020
Messages : 8

Re : Problème de migration V2 vers V3

Non, ii n'y a que le fichier renommé confv2.php.
Merci

Hors ligne

#4 22-11-2020 23:12:09

David
Développeur d'iGalerie
Inscription : 12-05-2006
Messages : 4 158
Site Web

Re : Problème de migration V2 vers V3

Il faut copier les fichiers de la version 3 dans le répertoire de la version 2, de telle sorte que le fichier "conf.php" de la version 3 se retrouve avec le fichier "confv2.php" dans le répertoire "config".

Hors ligne

#5 24-11-2020 10:22:47

gille.nicolas
Membre
Inscription : 22-11-2020
Messages : 8

Re : Problème de migration V2 vers V3

Un tout grand merci pour l'aide de Monsieur David.
Voir: http://perso.nicolasgf.be/igalerie
Une petite remarque: le fichier "conf.php" de la version 3 est automatiquement créé lors de l'installation.
Bien à Vous
Gille Nicolas

Hors ligne

#6 18-12-2020 12:52:39

gille.nicolas
Membre
Inscription : 22-11-2020
Messages : 8

Re : Problème de migration V2 vers V3

bonjour,
mon serveur local est maintenant en debian 10, php 7.4.
depuis la certification letsencrypt, dejà avec la version 2.4.13, j'ai un problème d'affichage lors d'un accès à distance: https://igalerie.perso.nicolasgf.be et sur le serveur: localhost/igalerie fonctionne très bien.?
Pensant que le passage à igalerie 3.0.8 allait résoudre le problème, je viens de l'exécuter mais c'est toujours le même.?
je joint la réponse de Letsencrypt à la question posée précédemment, toujours en version 2.4.9.

mais http ou https://igalerie.perso.nicolasgf.be me donne une structure texte du site ?  Pourquoi ?

It's because the stylesheet file blue.css
https://igalerie.perso.nicolasgf.be/iga … e/blue.css 1
doesn't exist at the indicated location.

Avant, sans le certificat, http://perso.nicolasgf.be/igalerie affichait correctement le site ?
It's possible that the structure of the site was different in some way that allowed the CSS stylesheet to be found with the old structure, but not with the new structure.

Pouvez-vous m'aider
Bien à Vous

Hors ligne

#7 18-12-2020 15:27:50

David
Développeur d'iGalerie
Inscription : 12-05-2006
Messages : 4 158
Site Web

Re : Problème de migration V2 vers V3

As-tu déplacé l'application dans un autre répertoire ? Car le problème semble venir de la constante CONF_GALLERY_PATH du fichier config/conf.php qui est mal renseignée. Elle est remplie au moment de l'installation, mais si tu déplaces iGalerie dans un autre répertoire il faut également modifier cette constante.

Dans ton cas, tu devrais la laisser vide :

define('CONF_GALLERY_PATH', '');

Il faudra aussi modifier la directive RewriteBase dans le fichier .htaccess pour que l'URL rewriting puisse fonctionner :

RewriteBase /

Hors ligne

#8 18-12-2020 16:36:39

gille.nicolas
Membre
Inscription : 22-11-2020
Messages : 8

Re : Problème de migration V2 vers V3

define('CONF_GALLERY_PATH', '');
config/conf.php ===> Impossible d’enregistrer la modification ===> utilisateur www-data pas de permission.
chown -R gille /var/www/html/igalerie/config/conf.php  ===>  l’enregistrement est fait et la 1er page s’affiche mais pas les suivantes ? ? ?

Je n'utilise pas .htaccess

Grand merci pour tout

Hors ligne

#9 18-12-2020 16:54:08

David
Développeur d'iGalerie
Inscription : 12-05-2006
Messages : 4 158
Site Web

Re : Problème de migration V2 vers V3

Car l'URL rewriting est activée. Il faut soit la désactiver (section Options en admin) ou soit modifier le fichier .htaccess d'iGalerie comme je l'ai indiqué.

Hors ligne

#10 19-12-2020 15:39:10

gille.nicolas
Membre
Inscription : 22-11-2020
Messages : 8

Re : Problème de migration V2 vers V3

Hors ligne

#11 21-12-2020 15:31:50

gille.nicolas
Membre
Inscription : 22-11-2020
Messages : 8

Re : Problème de migration V2 vers V3

Une dernière question qui n'est pas fonctionnelle.
Décidé a faire la mise à jour 3.0.9, sur le serveur, http://localhost/igalerie me donne encore une structure texte du site.
Merci d'avance pour la réponse !

Hors ligne

#12 25-01-2021 17:44:19

gille.nicolas
Membre
Inscription : 22-11-2020
Messages : 8

Re : Problème de migration V2 vers V3

Pour les besoins, j'ai installé une deuxième galerie 'igalerie2' accessible par localhost/igalerie2 mais
https://igalerie2.perso.nicolasgf.be n'affiche pas le site mais bien sa structure ? ?

Pour rappel, dans mon message précédent, avec igalerie, j'ai juste l'inverse !

Je joins la réponse Let'Encrypt : C'est parce que le fichier de feuille de style blue.css https://igalerie.perso.nicolasgf.be/iga … e/blue.css n'existe pas à l'emplacement indiqué.
Dans igalerie comme dans igalerie2,  "/template/default/style/blue " n'existe pas ?
Je n'ai rien déplacé ?
Merci d'avance pour votre aide

Hors ligne

#13 26-01-2021 10:55:23

David
Développeur d'iGalerie
Inscription : 12-05-2006
Messages : 4 158
Site Web

Re : Problème de migration V2 vers V3

Si le problème est identique, alors la réponse sera la même que celle que j'ai donné plus haut.

Hors ligne

Pied de page des forums