iGalerie

Vous n'êtes pas identifié(e).

Annonce

Version en développement : iGalerie 3.0

#1 02-03-2011 21:09:23

bluefox
Membre
Inscription : 16-03-2008
Messages : 20
Site Web

[Intégration] [UP] Rien ne s'affiche...

Bonjour,

J'utilise la version 1 d'i-galerie depuis 4 ans et souhaiterai l'embellir en l'intégrant dans
un interface plus jolie.
Mais je rencontre un problème lors de son "incrustation".

J'ai suivi les topics concernant et la documentation.
Après plusieurs essais, elle est apparue tout en bas, mais j'ai du trop bidouiller les codes pour qu'elle n'apparaisse plus du tout...
Et bien, ça doit être de ma faute, moi qui ait du mal faire trop vite (comme toujours...^^).
Quelle débutante...

Je m'en remets donc à vous et votre aide très précieuse pour résoudre ce casse-tête...
Je peux vous montrer mon fichier index.php si vous le désirez.

Voici le lien où devrait être affichée la galerie :
http://bleuecume.com/galerie/

Dernière modification par bluefox (07-09-2011 20:37:45)

Hors ligne

#2 03-03-2011 20:59:58

David
Développeur d'iGalerie
Inscription : 12-05-2006
Messages : 3 866
Site Web

Re : [Intégration] [UP] Rien ne s'affiche...

Salut,

Le problème c'est que tu as deux doctype dans ta page. Mais il faudrait plutôt que tu nous montre ton fichier index.php pour voir comment tu as placer les lignes d'inclusions d'iGalerie.

Hors ligne

#3 04-03-2011 14:45:16

bluefox
Membre
Inscription : 16-03-2008
Messages : 20
Site Web

Re : [Intégration] [UP] Rien ne s'affiche...

Merci de m'avoir répondu.
Voici la page index.php :

<?php require_once(dirname(__FILE__) . '/galerie.php'); ?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" dir="ltr" lang="en-US" xml:lang="en">
    <head>
        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
        <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE8" />
        <title>Bleu d'écume - Galerie</title>
        <link rel="stylesheet" href="http://bleuecume.com/galerie/theme/style.css" type="text/css" media="screen" />
        <!--[if IE 6]><link rel="stylesheet" href="http://bleuecume.com/galerie/theme/style.ie6.css" type="text/css" media="screen" /><![endif]-->
        <!--[if IE 7]><link rel="stylesheet" href="http://bleuecume.com/galerie/theme/style.ie7.css" type="text/css" media="screen" /><![endif]-->
        <link rel="shortcut icon" href="http://bleuecume.com/galerie/theme/favicon.ico" type="image/x-icon" />
        <script type="text/javascript" src="http://bleuecume.com/galerie/theme/jquery.js"></script>
        <script type="text/javascript" src="http://bleuecume.com/galerie/theme/script.js"></script>
<?php require_once(dirname(__FILE__) . '/entete.php'); ?>
    </head>
    <body>
        <div id="main">
            <div class="header">
                <div class="header-center">
                    <div class="header-jpeg"></div>
                </div>
                <div class="header-wrapper">
                    <div class="header-inner">
                        <div class="headerobject"></div>
                        </div>
                    </div>
                </div>
            </div>
            <div class="nav">
                <div class="nav-l"></div>
                <div class="nav-r"></div>
                <div class="nav-wrapper">
                    <div class="nav-inner">
                        <ul class="menu">
                            <li><a href="http://bleuecume.com/galerie/index.html" class="active"><span class="l">Accueil</span><span class="r"> </span><span class="t"> </span></a></li>
                        </ul>
                    </div>
                </div>
            </div>
            <div class="sheet">
                <div class="sheet-tl"></div>
                <div class="sheet-tr"></div>
                <div class="sheet-bl"></div>
                <div class="sheet-br"></div>
                <div class="sheet-tc"></div>
                <div class="sheet-bc"></div>
                <div class="sheet-cl"></div>
                <div class="sheet-cr"></div>
                <div class="sheet-cc"></div>
                <div class="sheet-body">
                    <div class="content-layout">
                        <div class="content-layout-row">
                            <div class="layout-cell sidebar1">
                                <div class="block">
                                    <div class="block-body">
                                        <div class="blockheader">
                                            <div class="l"></div>
                                            <div class="r"></div>
                                            <h3 class="t">Bienvenue</h3>
                                        </div>
                                        <div class="blockcontent">
                                            <div class="blockcontent-body">
                                                <p style="text-align: center; ">Bienvenue sur la galerie de Flake.</p>
                                                <p style="text-align: center; ">Ceci est un test d'intégration de la galerie.</p>
                                                <div class="cleared"></div>
                                            </div>
                                        </div>
                                        <div class="cleared"></div>
                                    </div>
                                </div>
                                <div class="cleared"></div>
                            </div>
                            <div class="layout-cell content">
                                <div class="post">
                                    <div class="post-body">
                                    <?php require_once(dirname(__FILE__) . '/' . IGAL_TEMPLATE); ?>
                                        <div class="post-inner article">
                                            <div class="postcontent">
                                            </div>
                                            <div class="cleared"></div>
                                        </div>
                                        <div class="cleared"></div>
                                    </div>
                                </div>
                                <div class="cleared"></div>
                            </div>
                        </div>
                    </div>
                    <div class="cleared"></div>
                    <div class="cleared"></div>
                </div>
            </div>
            <div class="footer">
                <div class="footer-body">
                    <div class="footer-text">
                        <p><a href="http://bleuecume.com/galerie/">Galerie</a> | <a href="http://bleuecume.com">Site</a> |  <a href="http://bleuecume.com/?page_id=10">Contact</a></p>
                        <p>Copyright © 2011. Bleu d'écume.</p>
                        <div class="cleared"></div>
                        <p class="page-footer">Design par <a href="http://bleuecume.com">Flake</a>.</p>
                    </div>
                    <div class="cleared"></div>
                </div>
            </div>
        </div>
    </body>
</html>

Hors ligne

#4 04-03-2011 16:26:16

David
Développeur d'iGalerie
Inscription : 12-05-2006
Messages : 3 866
Site Web

Re : [Intégration] [UP] Rien ne s'affiche...

Pour l'intégration d'iGalerie, le code est bon, mais il ne correspond pas vraiment au code source de ta page... Notamment, tu as un deuxième doctype qui n'apparaît pas dans ton fichier index.php. Donc il faudrait déjà que tu expliques d'où sort ce second doctype !

Hors ligne

#5 04-03-2011 16:39:31

bluefox
Membre
Inscription : 16-03-2008
Messages : 20
Site Web

Re : [Intégration] [UP] Rien ne s'affiche...

Je n'explique pas ce deuxième doctype...
Je vais tout simplement refaire le template et faire plus attention au code...

Hors ligne

#6 07-09-2011 20:54:12

bluefox
Membre
Inscription : 16-03-2008
Messages : 20
Site Web

Re : [Intégration] [UP] Rien ne s'affiche...

Bonjour, et désolée de répondre aussi tardivement, David.
Je vous remercie pour votre patience et pour votre explication claire, pour une débutante telle que moi.
Maintenant, j'ai pu acquérir quelques connaissances pour concevoir un thème mieux adapté, et l'intégration a bien fonctionné ! ^^


En effet, il y avait deux doctypes.
J'avais utilisé l'exemple d'intégration qui avait été fourni sur votre site pour ce premier design et n'avais pas suivi consciencieusement les étapes d'incorporation de la galerie.
Un petit tour sur le forum m'a permis de comprendre l'intégration de la galerie v.1 que j'utilise.

J'aurais cependant quelques derniers conseils à demander pour le finaliser (je vous embête encore...><) :

- Comment afficher les accents ?
- Dans quels fichiers je dois me rendre pour modifier les couleurs des vignettes en survol et autres éléments du template de la galerie ?
(Je ne veux pas faire de bétises !)

Merci d'avance et à très bientôt !

Ma page index.php :

<?php require_once(dirname(__FILE__) . '/galerie.php'); ?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="fr">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>Bleu d'écume - La Galerie</title>
<style type="text/css">
body {
    background-color: #16554d;
    background-image: url(images/page_gl.png);
    background-repeat: no-repeat;
}
body, td, th {
    font-family: Verdana, Arial, Helvetica, sans-serif;
    font-size: 12px;
    color: #008262;
    text-align: right;
}
</style>
<link href="style.css" rel="stylesheet" type="text/css" />
<style type="text/css">
a:link {
    color: #0C9;
    text-decoration: none;
}
a:visited {
    color: #096;
    text-decoration: none;
}
a:hover {
    color: #0FF;
    text-decoration: none;
}
a:active {
    color: #0C9;
    text-decoration: none;
    font-style: normal;
}
</style>
<?php require_once(dirname(__FILE__) . '/entete.php'); ?>
<link rel="shortcut icon" type="image/x-icon" href="/favicon.ico" />
</head>

<body>
<div id="page-content">
        <div id="banner">
                <div id="bloc-infos">
                        <div id="titre-bloc-infos"><img src="images/iconeBC.png" width="9" height="12" alt="icone-logoBC" /> 06/09/2011</div>
                        <br />
        Des projets sont en cours de réalisation et seront bientôt publiés dans la galerie. Patience...:3</div>
                z</div>
        <div id="main-content">
                <div id="nav-bar">
                        <div id="bloc-menu-navigation">                        
                                <div id="menu">
        <ul>
        <li><a href="/galerie/index.php">Galerie</a></li>
        <li><a href="http://bleuecume.com/">Site</a>
                
        </ul>
        </div></div>
                </div>
                <div id="zone-script-galerie">
                <?php require_once(dirname(__FILE__) . '/' . IGAL_TEMPLATE); ?></div>
                <div id="footer">
                        <table width="800" height="60" border="0" cellspacing="5" cellpadding="5">
                                <tr>
                                        <td colspan="2" rowspan="2"><div id="bloc-img-rss"><a href="http://bleuecume.com/?feed=rss2"><img src="images/rssicon.png" width="24" height="24" alt="RSS" longdesc="http://bleuecume.com/?feed=rss2" /></a></div></td>
                                        <td><a href="http://bleuecume.com/" title="Retour au site">Site</a> <span class="barre-blanche2">| </span><a href="/index.php" title="Retour à l'accueil de la galerie">Galerie</a> <span class="barre-blanche3">| </span><a href="http://bleuecume.com/?page_id=10" title="Ecrire au webmaster">Contact</a></td>
                                </tr>
                                <tr>
                                        <td><span class="texte-copyright">Toute reproduction interdite sauf sous autorisation de l'auteur</span>.</td>
                                </tr>
                        </table>
                </div>
        </div>
</div>
</div>
</body>
</html>

Hors ligne

#7 09-09-2011 21:11:46

David
Développeur d'iGalerie
Inscription : 12-05-2006
Messages : 3 866
Site Web

Re : [Intégration] [UP] Rien ne s'affiche...

bluefox a écrit :

- Comment afficher les accents ?

Sans doute avec le bon jeu de caractères. As-tu essayé avec l'ISO-8859-1 ?


bluefox a écrit :

- Dans quels fichiers je dois me rendre pour modifier les couleurs des vignettes en survol et autres éléments du template de la galerie ?

Tu peux ajouter de nouvelles règles CSS dans Options / "style additionnel", ou bien en modifiant le fichier CSS du style courant dans le répertoire "template" (template/defaut/style/defaut/defaut.css par exemple). Pour IE6 et IE7 il faudra modifier aussi le fichier galerie_style.js pour le hover des vignettes.

Hors ligne

#8 10-09-2011 12:14:14

bluefox
Membre
Inscription : 16-03-2008
Messages : 20
Site Web

Re : [Intégration] [UP] Rien ne s'affiche...

Merci pour votre aide, et pour la rapidité de votre réponse. big_smile
L'affichage des accents fonctionne, merci bien.

Je vous donnerai des nouvelles de la modification du template.
A bientôt.

Dernière modification par bluefox (10-09-2011 12:14:33)

Hors ligne

#9 15-09-2011 17:34:19

bluefox
Membre
Inscription : 16-03-2008
Messages : 20
Site Web

Re : [Intégration] [UP] Rien ne s'affiche...

Bonjour ! C'est encore moi ! Promis, c'est la dernière fois que je vous embête !
J'ai réussi à modifier quelques couleurs des éléments du template,
mais je n'arrive pas à changer les couleurs des vignettes survolées ainsi que leurs titres (en orange).
J'ai beau cherché dans le css (default), mais je ne trouve pas...
Pourriez-vous m'indiquer dans quelle section je dois me rendre exactement ? Merci d'avance !

 
*    - Vignettes
*    - Vignettes : catégories
*    - Vignettes : albums

Dernière modification par bluefox (15-09-2011 17:34:42)

Hors ligne

#10 16-09-2011 08:15:54

David
Développeur d'iGalerie
Inscription : 12-05-2006
Messages : 3 866
Site Web

Re : [Intégration] [UP] Rien ne s'affiche...

Les portions du code CSS à modifier sont celles-ci :

.vignettes .env2:hover {
    background-color: #FCF0DA;
    border-color: #D58B0B;
}

#vignettes_cat .v_thumb .env2:hover {
    border-color: #D58B0B;
}
#vignettes_cat .vignette_nom:hover {
    color: #D58B0B;
}
#vignettes_cat .env2:hover .vignette_nom {
    color: #D58B0B;
}

#vignettes_alb .env2:hover {
    background-color: #FCF0DA;
    border-color: #D58B0B;
}
#vignettes_alb .env2:hover .vignette_nom {
    color: #D58B0B;
}
#vignettes_alb .v_recent .env2:hover {
    border-color: #D58B0B;
    border-top-color: #BDCF7F;
    background-color: #FCF0DA;
}

Hors ligne

#11 19-09-2011 14:15:07

bluefox
Membre
Inscription : 16-03-2008
Messages : 20
Site Web

Re : [Intégration] [UP] Rien ne s'affiche...

Merci beaucoup, et à bientôt ! XD

Hors ligne

#12 29-09-2011 13:58:36

bluefox
Membre
Inscription : 16-03-2008
Messages : 20
Site Web

Re : [Intégration] [UP] Rien ne s'affiche...

Juste une petite question :
Pourquoi la galerie apparaît - elle tout à droite sur IExplorer ?
(J'avais pourtant testé avec Google Chrome, Firefox et l'Affichage en direct de Dreamweaver...)

Merci d'avance pour vos réponses ! Et encore désolée !

Hors ligne

#13 29-09-2011 14:31:49

David
Développeur d'iGalerie
Inscription : 12-05-2006
Messages : 3 866
Site Web

Re : [Intégration] [UP] Rien ne s'affiche...

C'est à cause du commentaire avant le doctype. Tu dois supprimer la ligne 423 du fichier galerie.php :

echo "<!-- GALERIE MODE INTEGRATED -->\n";

Hors ligne

#14 29-09-2011 16:43:28

bluefox
Membre
Inscription : 16-03-2008
Messages : 20
Site Web

Re : [Intégration] [UP] Rien ne s'affiche...

Je ne sais comment vous remercier de nouveau...
Merci d'avoir été très disponible à mes requêtes.

Hors ligne

Pied de page des forums