iGalerie

Vous n'êtes pas identifié(e).

#1 Re : Installation » Installation 3.0.9 » 31-12-2020 10:49:05

Salut,
c'est passé en manuel ... j'ai créé le message pour remonter l'information. Des fois que ça t'aide wink

Passe un bon réveillon.

#2 Installation » Installation 3.0.9 » 28-12-2020 20:59:36

Reuns
Réponses : 2

Bonsoir David,

Je suis actuellement en 3.0.7,
Mon tableau de bord m'indique

La version 3.0.9 est disponible.

Cliquez ici pour l'installer.

Avec pour lien https://MONSITEWEB/admin/?q=update/1
Or ce lien me mène à une page blanche sans aucune information

Voici le bel incident qui apparait dans la liste des incidents

#6
Date : 2020-12-28 19:02:39.631952
Version : 3.0.7
Type : PHP_EXCEPTION
Fichier : includes/admin/classes/Admin.class.php
Ligne : 841
Page : update/1
Message : version_compare() expects parameter 2 to be string, float given

Merci pour ton aide.

#3 Re : Utilisation » Plus aucune aide » 28-12-2020 19:59:14

Bonjour Roland,
David fait du super travail et prends en plus le temps de faire le suivi sur le forum.

Avant de l'accuser de la sorte, tâche de faire quelques vérifications d'usage : tu verras que David a répondu à ta question 2 jours après.

C'est dommage d’entacher David de la sorte quand le problème ne vient pas de lui...

#4 Re : Discussions » V3 > A propos > Changelog » 24-11-2020 14:00:53

Salut Jac52.
Vérifie le forum, c'est revenu (je ne sais pas quand, ça fait quelques temps que je ne suis pas revenu)
wink

#5 Discussions » V3 > A propos > Changelog » 09-11-2020 16:30:29

Reuns
Réponses : 2

Salut David,

Le changelog de la v3 (ainsi que la page "A propos" du forum) a disparu...
C'est dommage, je consulte systématiquement cette page que je trouve très pratique.
Une erreur de manip ou un changement de cap ?

A+

#6 Re : Utilisation » Outils manquant » 27-08-2020 16:36:35

Ok... J'ai trouvé !
Ma fenêtre était trop petite (je ne travaille jamais en plein écran).
Du coup les outils n'apparaissaient pas.

Je vois maintenant les outils.
Bon ... il n'y a plus qu'à attendre les futures mise à jour pour le reste.

Ta réponse va au-delà de mes attentes, tu es au top: merci !
Bonne fin de journée.

#7 Re : Utilisation » Outils manquant » 27-08-2020 16:30:26

Salut,

Merci pour ta réponse. Que des bonnes nouvelles dedans ...
Toutefois, je ne m'y retrouve pas.
Pour la page activité : c'est tout bon ! C'est top !
Par contre, je suis incapable de trouver l'onglet "Modifications" ou même "Sélection". Est-ce une option que j'aurais désactivé ?

Un coup de main supplémentaire ne serait pas de refus.

Reuns

#8 Utilisation » Outils manquant » 26-08-2020 14:53:41

Reuns
Réponses : 3

Salut David,


Je viens d'ajouter des images sur ma galerie (je ne l'avais pas fait depuis la migration en v3) et voici les outils qui me manquent.
* modification en masse.
* modification des coordonnées gps depuis la grille des images.
* l'autocomplétion à la saisie des tags.
* La possibilité de chercher un lieu sur la carte en tapant le nom d'une ville
* La page activité ne montre que les erreurs de connexion. Avoir accès aux connexions réussis est vraiment un plus.

Autant d'outils dont j'avais pris l'habitude d'utiliser en V2 et que je ne retrouve pas ici.

Penses-tu les réintégrer dans un futur ?

Merci
Reuns

#9 Re : Installation » Mise à jour depuis igalerie 2. » 27-05-2020 08:31:17

Bonne nouvelle si la section "Activité" est de nouveau envisagé.
Pour le rappel du mot de passe ... ça fonctionne.
Je n'ai rien changé et maintenant ça passe.
Je ne comprends pas pourquoi je n'ai pas réussit à le faire fonctionner la première fois. J'avais essayé un peu toute les combinaisons... Bref !

Vivement les prochaines mise à jour.
Prends ton temps, tu fais du beau boulot.
Merci.

#10 Re : Installation » Mise à jour depuis igalerie 2. » 25-05-2020 08:48:24

Bonjour David,

Je suis passé sur la v3 grace à ton script de migration.
Impeccable, tout fonctionne bien en apparence, mais ...

Les utilisateurs ne peuvent pas se connecter. C'est normal, tu m'avais prévenu. Je clique sur oublie du mot de passe, je tape le nom d'utilisateur, l'adresse e-mail ... et là, c'est le drame smile j'ai le message "Information incorrect" alors que les informations sont bonnes.
Une aide serait salvatrice de ce coté là.

Merci.

PS : Je remarque au passage que dans l'interface Admin, il n'existe plus la page "Activité" qui me permettais de voir qui se connecte, à quel moment ... et surtout les erreurs de connexion. (Est-il prévu qu'elle revienne dans une prochaine mise à jour).

#11 Re : Utilisation » Télécharger l'album » 23-05-2020 20:45:56

Super !
Merci pour l'info.

Beau boulot une fois de plus.
A+

#12 Utilisation » Télécharger l'album » 23-05-2020 09:50:46

Reuns
Réponses : 2

Bonjour David,

Sur la V2, les visiteurs avaient la possibilité de télécharger l'album sur lequel ils se trouvaient.
Impossible de retrouver cette option sur la V3. Peux-tu m'aider à la retrouver ... cette option est juste parfaite.

Si jamais (comme je le crains) elle n'existe plus, t'est-il possible de la remettre en place ?

Merci,
Reuns

#13 Re : Installation » Mise à jour depuis igalerie 2. » 15-05-2020 14:05:57

Bonjour David,

Ooopss, mauvaise manip' de ma part.
Oublie ce message, merci. (pardon)

#14 Re : Installation » Mise à jour depuis igalerie 2. » 14-05-2020 11:09:23

Super, je vais y jeter un oeil de ce pas.
Merci

#15 Re : Installation » Mise à jour depuis igalerie 2. » 27-04-2020 16:56:28

Salut,

Pas de soucis, je ne suis pas pressé. C'est tout ce que j'avais besoin de lire.
Grand merci à toi wink

#16 Installation » Mise à jour depuis igalerie 2. » 27-04-2020 08:53:41

Reuns
Réponses : 8

Bonjour David,
Je suis les mises à jour régulièrement de igalerie que j'utilise depuis sa version 2.
J'ai été très heureux d'apprendre qu'une version 3 était sur les rails ... mais là je suis un peu surpris. Je ne trouve aucune procédure de migration de la version 2 vers la version 3.

Si une telle procédure existe, elle n'est clairement pas mise en avant. Sinon est-ce que c'est quelques choses qui est en train de se faire de ton coté, ou faut-il faire une croix dessus ? sad
Tu imagines bien que perdre tout un historique est assez rédhibitoire...

A+ et encore merci pour ce boulot de titan accompli !
Reuns

#17 Re : Bugs » Notification par e-mail incomplète » 10-01-2020 16:43:53

Les notifications quand je mets de nouvelles images dans la galerie par exemple.
Les utilisateurs reçoivent un e-mail les informant des nouvelles images (ou de nouveaux commentaires sur une photo qu'ils ont déjà commenté). C'est de cette notification là dont je parle.

Il m'arrive d'avoir 1 ou deux incidents (mais ça se produit extrêmement rarement)
Voici une copie du dernier en date

54     détails    
Date     2020-01-09 14:39:17
Version     2.4.12
Type     PHP_NOTICE
Fichier     index.php
Ligne     5936
Page     image/3952-7
Message    
unserialize(): Error at offset 402 of 1508 bytes
Détails    

Array
(
    [sql] => SELECT img.image_id,
                       img.cat_id,
                       image_path,
                       image_width,
                       image_height,
                       image_filesize,
                       image_exif,
                       image_iptc,
                       image_xmp,
                       image_lat,
                       image_long,
                       image_place,
                       image_name,
                       image_url,
                       image_desc,
                       image_adddt,
                       image_crtdt,
                       image_hits,
                       image_votes,
                       image_rate,
                       image_rotation,
                       image_comments,
                       image_status,
                       cat_filemtime,
                       cat_password,
                       cat_commentable,
                       cat_votable,
                       cat_path,
                       cat_url,
                       cat_style,
                       cat_orderby,
                       cat_watermark,
                       u.user_id,
                       u.user_login,
                       u.user_avatar,
                       u.user_status,
                       u.user_watermark
                       , (SELECT 1
                          FROM igal2_favorites
                         WHERE image_id = img.image_id
                           AND user_id = :user_id
                         LIMIT 1) AS in_favorites, (SELECT 1
                              FROM igal2_basket
                             WHERE image_id = img.image_id
                               AND user_id = :user_id
                             LIMIT 1) AS in_basket, (SELECT vote_rate
                              FROM igal2_votes
                             WHERE image_id = img.image_id
                               AND user_id = :user_id
                             LIMIT 1) AS user_rate, (SELECT COUNT(*)
                          FROM igal2_users
                     LEFT JOIN igal2_favorites USING (user_id)
                         WHERE user_status = "1"
                           AND image_id = img.image_id) AS nb_favorites
                  FROM igal2_images AS img
             LEFT JOIN igal2_users AS u
                    ON img.user_id = u.user_id
             LEFT JOIN igal2_categories AS cat
                    ON img.cat_id = cat.cat_id
                 WHERE img.image_id = :image_id
                   AND img.image_status = "1" AND (cat.cat_id IN (1, 2, 4, 59) OR cat_parents LIKE "%:2:%" OR cat_parents LIKE "%:4:%" OR cat_parents LIKE "%:59:%")
    [params] => Array
        (
            [user_id] => 21
            [image_id] => 3952
        )

    [resize] =>
    [watermark] =>
)

#18 Bugs » Notification par e-mail incomplète » 10-01-2020 15:24:38

Reuns
Réponses : 2

Bonjour David,

J'ai un problème sur les notifications par e-mail.
J'ai personnalisé mes notifications avec les paramètres donnés
{AUTHOR} : auteur {GALLERY_TITLE} : titre de la galerie {GALLERY_URL} : URL de la galerie {IMAGE_URL} : URL de l'image {EMAIL} : courriel {WEBSITE} : site Web

mais ceux-ci ne fonctionnent pas.
Du coup les utilisateurs reçoivent des messages avec des blancs, sans l'url de la galerie concerné ni rien.

Ce problème existe depuis la première version que j'ai installé (2.4.2). Je ne peux pas donc pas dire à partir de quelle version ça a commencé à bugger.

En tout état de cause, si tu avais un petit patch à proposer, ce serait vraiment sympa.
A moins que le problème ne vienne que de mon installation et dans ce cas, si tu as une idée d'où ça vient, je suis preneur.

Merci...
Reunsss

#19 Re : Discussions » iGalerie 3.0 » 10-01-2020 15:18:43

Salut David,
Voila une super nouvelle !
Vivement une version de production. ^^

#20 Bugs » Perte de la Clé pour l'API Google Maps » 16-10-2019 12:06:36

Reuns
Réponses : 0

David,

Pour information, suite à la migration vers la version 2.4.12 (merci pour tes mises à jour) le champs "Clé pour l'API Google Maps" a été réinitialisé.

Retrouver la clé n'étant pas toujours aisé ... peut être qu'une mise à jour de ta release serait utile.

A bon entendeur ;)

#21 Re : Bugs » Titre des albums disparut » 16-09-2019 14:06:27

Vraisemblablement, j'ai rencontré le même bug que pas mal de monde : A savoir la langue FR qui a disparut.
J'ai pu renvoyer la langue FR, ce qui m'a fait apparaitre les champs "titre" des albums. A partir de là, j'ai retapé le nom des albums (facilement reconstructible grace aux url des albums). Toutefois, je ne comprends pas comment ceux-ci ont pu disparaitre. Mais cela semble lié à mon passage en version 2.4.11. (Aucun lien avec la migration de OVH du coup)

Par contre, je ne comprends toujours pas à quoi sont du les incidents qui sont remontés dans la console (pas de nouveaux incidents depuis mon dernier message).

#22 Re : Bugs » Titre des albums disparut » 12-09-2019 18:18:37

J'ai également quelques incidents depuis cette migration (alors que je n'en avais pas auparavant)

48     détails    
Date     2019-09-12 18:12:47
Version     2.4.11
Type     PHP_WARNING
Fichier     admin/index.php
Ligne     25885
Page     options-gallery
Message    
Invalid argument supplied for foreach()
#     47     détails    
Date     2019-09-12 18:08:30
Version     2.4.11
Type     PHP_WARNING
Fichier     admin/index.php
Ligne     25899
Page     options-gallery
Message    
Invalid argument supplied for foreach()
#     46     détails    
Date     2019-09-12 16:43:21
Version     2.4.11
Type     PHP_ERROR
Fichier     includes/classes/db.class.php
Ligne     326
Page     options-gallery
Message    
Uncaught Error: Call to a member function query() on null in /includes/classes/db.class.php:326
Stack trace:
#0 /includes/classes/mail.class.php(43): db->query('SELECT user_ema...', 'row')
#1 /includes/classes/errorHandler.class.php(459): mail::getAdminInfos()
#2 /includes/classes/errorHandler.class.php(338): errorHandler::_mail('PHP_EXCEPTION', 'includes/classe...', 326, 'Call to a membe...', 'a:10:{i:0;a:6:{...')
#3 /includes/classes/errorHandler.class.php(356): errorHandler::_log('PHP_EXCEPTION', 'includes/classe...', 326, 'Call to a membe...', 'a:10:{i:0;a:6:{...')
#4 /includes/classes/errorHandler.class.php(148): errorHandler::_display('PHP_EXCEPTION', 'includes/classe...', 326, 'Call to a membe...', Array)
#5 /includes/classes/errorHandler.class.php(111): errorHandler::phpError(0, 'Call to a membe...', 'includes/classe...', 326, Array)
#6 [internal function]: errorH
#     45     détails    
Date     2019-09-12 16:43:21
Version     2.4.11
Type     PHP_EXCEPTION
Fichier     includes/classes/db.class.php
Ligne     326
Page     options-gallery
Message    
Call to a member function query() on null
#     44     détails    
Date     2019-09-12 16:43:21
Version     2.4.11
Type     PHP_WARNING
Fichier     admin/index.php
Ligne     25771
Page     options-gallery
Message    
count(): Parameter must be an array or an object that implements Countable
#     43     détails    
Date     2019-09-12 12:22:04
Version     2.4.11
Type     PHP_NOTICE
Fichier     admin/connexion.php
Ligne     159
Page     session-expire
Message    
unserialize(): Error at offset 31 of 33 bytes
#     42     détails    
Date     2019-09-12 07:04:01
Version     2.4.11
Type     PHP_NOTICE
Fichier     admin/index.php
Ligne     3240
Page     category/4
Message    
unserialize(): Error at offset 31 of 33 bytes
#     41     détails    
Date     2019-09-12 04:02:32
Version     2.4.11
Type     PHP_WARNING
Fichier     includes/classes/template.class.php
Ligne     865
Page     register
Message    
Invalid argument supplied for foreach()
#     40     détails    
Date     2019-09-12 04:02:24
Version     2.4.11
Type     PHP_WARNING
Fichier     includes/classes/utils.class.php
Ligne     817
Page     login
Message    
Invalid argument supplied for foreach()
#     39     détails    
Date     2019-09-12 02:18:59
Version     2.4.11
Type     PHP_NOTICE
Fichier     includes/classes/utils.class.php
Ligne     521
Page     image/2180-2016-08-07-13h56m30
Message    
unserialize(): Error at offset 31 of 33 bytes

#23 Bugs » Titre des albums disparut » 12-09-2019 16:41:31

Reuns
Réponses : 2

Bonjour David,

OVH a migré mes données (pour des raisons propre à son infrastructure, je n'ai rien demandé).
Les disposition de cette migration sont consultable ici : https://www.ovh.com/fr/webhosting-migration/

Suite à cette migration je constate que certains de mes albums n'ont plus de titre (exemple : https://petitboutdevie.fr/erreurgalerie.jpg) Sur cet exemple seul 2 albums ont conservé leur titre. C'est parfois plus, parfois moins. Le problème apparait bien évidement sur les site également (et pas seulement dans le Back Office).
Pourtant, dans l'onglet "Informations" on a bien les informations souhaité.

Comment faire pour récupérer ces informations SVP ?

Merci pour ton aide.
Reuns

#24 Re : Bugs » Tri des images par nom de fichier » 17-06-2019 10:54:59

Encore une fois, une réponse impeccable.

Merci à toi.
(PS :  la modif pourrait être utile à pas mal de monde, mais c'est toi qui voit ^^)

#25 Bugs » Tri des images par nom de fichier » 17-06-2019 09:24:23

Reuns
Réponses : 2

Bonjour David,

J'ai un problème lorsque l'on effectue un tri des images par nom de fichier.
J'ai une suite d'image qui doit être afficher dans un ordre précis. J'ai nommé l'ensemble de mes images : 1.jpg, 2.jpg, 3.jpg, 4.jpg, 5.jpg ... 59.jpg

Toutefois, le classement se fait de la sorte :
1, 10, 11, 12, ..., 19, 2, 20, 21 ,22... 29, 3, 30, 31, ...

Du coup, le tri ne fonctionne plus correctement.
Soit j'ai zappé une option, soit on a besoin d'un correctif.
Peux-tu éclairer ma lanterne stp ?

Merci.

PS : Si tu fais un patch, j'avais fait une petite modification sur ton thème de base, pour faciliter la navigation sur smartphone... si tu pouvais l'intégrer à ta distribution, ça profiterais à tous, sans avoir besoin de re-modifier le fichier css systématiquement. Merci ^^
http://www.igalerie.org/forum/viewtopic.php?id=2977

Pied de page des forums

Propulsé par FluxBB