iGalerie

Vous n'êtes pas identifié(e).

#1 28-08-2020 11:57:15

RV
Membre
Inscription : 17-01-2014
Messages : 47

VirtualHost et .htaccess conflit? RewriteEngine ?

Salut,

En faisant quelques essais sur un raspberry équipé d'un serveur apache2 avec le VirtualHost suivant :

 
<VirtualHost *:80>
        ServerName test.mondomaine.fr
        ServerAdmin webmaster@mondomaine.fr
        DocumentRoot  /var/www/html/test/
#  ....
</VirtualHost>

je n'arrive pas à comprendre que lorsque je dépose des pages simples index.html
tout se passe bien. Le navigateur affiche dans http://test.mondomaine.fr la page index.html présente. Si je créé un dossier /var/www/html/test/test1 avec un fichier index.html dedans, l'adresse http://test.mondomaine.fr/test1 affiche bien le fichier index.html contenu dedans. Jusque là tout va bien smile

Si j'installe igalerie3 dans le répertoire /var/www/html/test/, patatras, la page d'accueil (depuis l'extérieur toujours) http://test.mondomaine.fr affiche une page sans style remplie d'erreurs 404. Chaque clic affiche "Internal Server Error" en tentant d'afficher la page http://test.mondomaine.fr/test - ce qui ne devrait pas se produire si j'ai bien compris la fonction du VirtualHost.

L'accès en local via l'adresse http://192.168.0.xxx/test fonctionne parfaitement (sans VirtualHost défini)

Mes connaissances étant ultra limitées, j'ai du rater quelque chose quelque part, mais où?
Le module rewrite dans le fichier .htaccess à la racine? Le fichier de conf du VirtualHost?
Merci
@+

Dernière modification par RV (28-08-2020 14:35:52)

Hors ligne

#2 28-08-2020 21:24:07

RV
Membre
Inscription : 17-01-2014
Messages : 47

Re : VirtualHost et .htaccess conflit? RewriteEngine ?

Re-salut,

J'ai identifié le problème : j'ai "installé" igalerie3 localement et créé le VirtualHost après ... les noms des dossiers vus de l'extérieurs n'étaient pas bons!
Donc, en modifiant la valeur dans /config/conf.php :

define('CONF_GALLERY_PATH', 'test'); 

par

define('CONF_GALLERY_PATH', '');

et dans le fichier .htaccess à la racine de la galerie :

RewriteBase /test/

par

RewriteBase /

tout marche à merveille smile depuis l'extérieur uniquement sad je peux accéder à la galerie depuis son adresse publique. Depuis mon LAN, pas d'accès ni avec l'adresse IP locale ni avec celle publique ... merci à la LiveBox3 qui ne gère pas le DNS LoopBack sad

Si quelqu'un a un tuyau, je prends.

Hors ligne

Pied de page des forums