iGalerie

Vous n'êtes pas identifié(e).

Annonce

Un message d'erreur qui s'affiche ? Un mot de passe oublié ? L'ajout de fichier qui ne marche pas ?
Pensez d'abord à lire la FAQ, vous y trouverez probablement une solution à votre problème.

#1 09-02-2023 13:06:18

PYACESSON
Membre
Lieu : Chantepie (nouvelle adresse)
Inscription : 05-05-2009
Messages : 69
Site Web

[RESOLU] Mot de passe ADMIN

Bonjour David, j'ai un nouveau problème avec ma iGalerie3 : je ne peux plus me connecter à ma page ADMIN !!!
(je ne peux donc même pas regarder mes messages d'erreurs, puisque je ne peux aller dans ADMIN)
Le code est refusé. J'ai essayé ta méthode avec le script.php à la racine de la galerie, mais il ne se passe rien .
J'ai effacé mes cookies.
J'ai demandé un nouveau code d'accès, mais là aussi ça ne fonctionne pas.
Le message d'erreur en bas à gauche est : attaque par force brute détectée.
As-tu une idée avant de tout réinstaller ? (pour info : je dispose de plusieurs sauvegardes de ma base SQL si besoin)
Je te remercie d'avance, excellente journée, Pierre-Yves

Dernière modification par PYACESSON (14-09-2023 00:29:26)

Hors ligne

#2 09-02-2023 19:22:00

PYACESSON
Membre
Lieu : Chantepie (nouvelle adresse)
Inscription : 05-05-2009
Messages : 69
Site Web

Re : [RESOLU] Mot de passe ADMIN

David, je t'envoie ce second message car en changeant de navigateur (safari à la place de Chrome) et en désactivant mon antivirus, j'ai réussi à me re-connecter ! je vais tester encore avant de dire que c'est reglé.

Pour info, je retrouve maintenant dans les erreurs les messages suivants :

#5
Date : 2023-02-09 18:24:42.477260
iGalerie : 3.0.19
PHP : 8.0.19
Type : PHP_WARNING
Fichier : template/default/custom/head.tpl.php
Ligne : 41
Page : 404
Message : Trying to access array offset on value of type null
Trace : #1 index.php(23): require_once('/home/aupiednez...')#2 template/default/index.tpl.php(79): include_once('/home/aupiednez...')
#4
Date : 2023-02-09 18:24:42.476535
iGalerie : 3.0.19
PHP : 8.0.19
Type : PHP_WARNING
Fichier : template/default/custom/head.tpl.php
Ligne : 41
Page : 404
Message : Undefined array key "item"
Trace : #1 index.php(23): require_once('/home/aupiednez...')#2 template/default/index.tpl.php(79): include_once('/home/aupiednez...')
#3
Date : 2023-02-09 18:24:42.475832
iGalerie : 3.0.19
PHP : 8.0.19
Type : PHP_WARNING
Fichier : template/default/custom/head.tpl.php
Ligne : 14
Page : 404
Message : Trying to access array offset on value of type null
Trace : #1 index.php(23): require_once('/home/aupiednez...')#2 template/default/index.tpl.php(79): include_once('/home/aupiednez...')
#2
Date : 2023-02-09 18:24:42.474905
iGalerie : 3.0.19
PHP : 8.0.19
Type : PHP_WARNING
Fichier : template/default/custom/head.tpl.php
Ligne : 14
Page : 404
Message : Undefined array key "item"
Trace : #1 index.php(23): require_once('/home/aupiednez...')#2 template/default/index.tpl.php(79): include_once('/home/aupiednez...')
#1
Date : 2023-02-09 18:24:01.328646
iGalerie : 3.0.19
PHP : 8.0.19
Type : PHP_WARNING
Fichier : includes/core/File.class.php
Ligne : 301
Page : 404
Message : touch(): Utime failed: No such file or directory

La ligne 41 de mon fichier  template/default/custom/head.tpl.php :
"url": "<?php echo GALLERY_HOST . $tpl['item']['source']; ?>",

Bonne soirée, Pierre-Yves

Dernière modification par PYACESSON (09-02-2023 19:31:29)

Hors ligne

#3 30-03-2023 19:07:38

PYACESSON
Membre
Lieu : Chantepie (nouvelle adresse)
Inscription : 05-05-2009
Messages : 69
Site Web

Re : [RESOLU] Mot de passe ADMIN

Bonjour David, je reviens vers toi car j'ai à NOUVEAU le problème de connexion à l'ADMIN
J'ai essayé d'utiliser ta méthode avec le fichier php à la racine, mais il ne se passe rien !!!
Je n'ai aucun message de confirmation pour savoir si la modification est validée.
J'ai effacé tous les dossiers, réinstallé tout, arrêté mon anti-virus, changé de navigateur, Je viens même de remettre une sauvegarde de ma base SQL du mois dernier, mais ça ne change rien ...
Rien ne fonctionne, pas moyen de me connecter à l'Admin. J'ai essayé à partir de 3 PC différents. Mon site est hébergé chez OVH. Peut-on retrouver les infos dans la base sql ? As-tu une idée ? je te remercie d'avance, Pierre-Yves

Dernière modification par PYACESSON (31-03-2023 10:36:57)

Hors ligne

#4 31-03-2023 13:42:31

David
Développeur d'iGalerie
Inscription : 12-05-2006
Messages : 4 316
Site Web

Re : [RESOLU] Mot de passe ADMIN

Salut,

Le script pour définir un nouveau mot de passe disponible dans la FAQ ne fonctionnait qu'avec des versions plus anciennes d'iGalerie 3. Donc je t'invites à réessayer car je viens de le mettre à jour pour le rendre compatible avec la dernière version.

https://www.igalerie.org/documentation/ … nistration

Hors ligne

#5 31-03-2023 14:32:57

PYACESSON
Membre
Lieu : Chantepie (nouvelle adresse)
Inscription : 05-05-2009
Messages : 69
Site Web

Re : [RESOLU] Mot de passe ADMIN

Merci encore David pour ta réponse. Il y a du progrès car le message Modifications enregistrées ! apparait pour confirmer la mise à jour. Malheureusement les mots de passe et code d'accès renseignés dans le fichier php ne fonctionne toujours pas ! j'ai toujours la réponse "une erreur s'est produite"

Dernière modification par PYACESSON (31-03-2023 14:33:44)

Hors ligne

#6 31-03-2023 14:39:41

PYACESSON
Membre
Lieu : Chantepie (nouvelle adresse)
Inscription : 05-05-2009
Messages : 69
Site Web

Re : [RESOLU] Mot de passe ADMIN

Je modifie ma réponse précédente car en changeant de navigateur (sur Safari au lieu de Chrome) et arrêtant l'anti-virus j'ai enfin RÉUSSI à me reconnecter à ma page ADMIN !!! En espérant que mon problème puisse être utile à d'autres membres du forum. Bravo et encore un grand merci à toi David, excellente journée, cordialement, Pierre-Yves

Hors ligne

#7 31-03-2023 14:47:30

PYACESSON
Membre
Lieu : Chantepie (nouvelle adresse)
Inscription : 05-05-2009
Messages : 69
Site Web

Re : [RESOLU] Mot de passe ADMIN

Je confirme la question résolue et le sujet clos !!!

Hors ligne

#8 13-09-2023 11:22:44

PYACESSON
Membre
Lieu : Chantepie (nouvelle adresse)
Inscription : 05-05-2009
Messages : 69
Site Web

Re : [RESOLU] Mot de passe ADMIN

Bonjour David, je reviens vers toi, car mon problème d'identification à la page d'administration de ma galerie revient et c'est très désagréable.
J'ai tout essayé, en effectuant les procédures suivantes :
1/ j'ai utilisé le fichier PHP pour modifier le mot de passe, idem
2/ j'ai utilisé deux autres navigateurs, c'est la même chose.
3/ j'ai désactivé l'antivirus, idem.
4/ code error ci-dessous pour info (récupéré par FTP dans dossier error)
Je ne sais plus quoi faire, as-tu une solution ? Je te remercie d'avance, cordialement, Pierre-Yves

<?xml version="1.0" encoding="UTF-8" ?>
<error md5="4cb78db73c013365c5cb469551c83fdf">
	<app_version>3.0.20</app_version>
	<php_version>8.0.30</php_version>
	<type>MYSQL_ERROR</type>
	<date>2023-09-13 11:09:12.938853</date>
	<q>login</q>
	<file>includes%2Fcore%2FDB.class.php</file>
	<line>298</line>
	<message>SQLSTATE%5B23000%5D%3A+Integrity+constraint+violation%3A+1062+Duplicate+entry+%2736-1%27+for+key+%27igal3_sessions_users_uk1%27</message>
	<trace>%5B%22%231+admin%5C%2Findex.php%2818%29%3A+Admin%3A%3Astart%28%29%22%2C%22%232+includes%5C%2Fadmin%5C%2Fclasses%5C%2FAdmin.class.php%28753%29%3A+require_once%28%27%5C%2Fhome%5C%2Faupiednez...%27%29%22%2C%22%233+includes%5C%2Fadmin%5C%2Flogin.php%2822%29%3A+AdminConnection%3A%3Alogin%28%29%22%2C%22%234+includes%5C%2Fadmin%5C%2Fclasses%5C%2FAdminConnection.class.php%2830%29%3A+Auth%3A%3Aform%28%29%22%2C%22%235+includes%5C%2Fcore%5C%2FAuth.class.php%28385%29%3A+DB%3A%3Aexecute%28%27INSERT+INTO+iga...%27%2C+Array%29%22%5D</trace>
</error>

Dernière modification par PYACESSON (13-09-2023 16:24:57)

Hors ligne

#9 13-09-2023 20:21:32

David
Développeur d'iGalerie
Inscription : 12-05-2006
Messages : 4 316
Site Web

Re : [RESOLU] Mot de passe ADMIN

Salut,

Essayes en remplaçant la ligne 384 du fichier includes/core/Auth.class.php :

$sql = 'INSERT INTO {sessions_users} (session_id, user_id) VALUES (?, ?)';

par celle-ci :

$sql = 'INSERT IGNORE INTO {sessions_users} (session_id, user_id) VALUES (?, ?)';

Hors ligne

#10 13-09-2023 23:11:26

PYACESSON
Membre
Lieu : Chantepie (nouvelle adresse)
Inscription : 05-05-2009
Messages : 69
Site Web

Re : [RESOLU] Mot de passe ADMIN

Bonsoir et merci infiniment David, tu m'as sauvé comme à chaque fois !
Ça fonctionne parfaitement. Le commentaire suivant est écrit au dessus de la ligne :
// On associe l'identifiant de session avec l'utilisateur. Cela veut-il dire qu'il y avait un probleme de session et d'identifiant ?
J'espère qu'à la prochaine version et mise à jour d'iGalerie je ne retrouverai pas le problème.
Excellente soirée, Pierre-Yves

Dernière modification par PYACESSON (14-09-2023 00:21:46)

Hors ligne

Pied de page des forums