iGalerie

Vous n'êtes pas identifié(e).

Annonce

Un message d'erreur qui s'affiche ? Un mot de passe oublié ? L'ajout de fichier qui ne marche pas ?
Pensez d'abord à lire la FAQ, vous y trouverez probablement une solution à votre problème.

#1 29-09-2023 22:59:18

mmag
Membre
Lieu : Toul
Inscription : 15-08-2014
Messages : 54
Site Web

Disfonctionnements dans les réactions de la galerie

Bonjour.

J'ai un problème récurent sur la galerie galerie.gpmt.fr. Je viens de réinstaller la galerie sous galerienew.gpmt.fr. Les problèmes n'ont pas disparu.
La galerie fonctionne sous PHP 7.3.1 (ce peut-être une raison du disfonctionnement ? Ma galerie perso n'a pas ces problèmes sous PHP 8.1)
- Sur mon ordinateur, je n'ai pas de problème : les différentes fonctions marchent normalement.
- Sur un autre ordinateur, les problèmes existent (Windows et Apple) sur tous les navigateurs. Est-ce que cela peut être un soucis entre http et https ?

- Si je peux atteindre un album : les vignettes s'affichent normalement, mais si je demande la lecture des images, les images ne s'affichent pas. Apparemment, les images ne sont pas trouvées sur le serveur.
- Si je peux obtenir un fonctionnement normal sur une première visite du site, dès la deuxième visite, les disfonctionnements sont là.
- Un utilisateur ne peut pas se connecter. (J'ai créé un utilisateur David avec le pass david pour pouvoir faire les essais).
- Je n'arrive pas à valider les commentaires dans les fonctionnalités.
- Les défauts arrivent les uns après les autres dans les différents étages au fur et à mesure de l'utilisation.

Lors d'une première discussion, David m'a parlé des possibilités de redimensionnement des images. Ces fonctions ne sont pas activées.

Pourriez-vous regarder pourquoi nous avons ces disfonctionnements ?

Merci pour votre intervention.

Cordialement.

Michel MAGNIER

Hors ligne

#2 29-09-2023 23:09:59

mmag
Membre
Lieu : Toul
Inscription : 15-08-2014
Messages : 54
Site Web

Re : Disfonctionnements dans les réactions de la galerie

Petit problème : le mot de passe doit avoir au moins 6 caractères. Donc, pour l'utilisateur spécial David, le pass est davide.

J'ai créé une adresse mail bidon : david@igalerie.fr. Donc, ne pas attendre un retour automatique !

Les problèmes viennent peut-être du fait que les recherchent sur le serveur n'arrivent pas à trouver ce qu'elles cherchent.

Cordialement.

Dernière modification par mmag (29-09-2023 23:14:12)

Hors ligne

#3 30-09-2023 10:11:09

David
Développeur d'iGalerie
Inscription : 12-05-2006
Messages : 4 353
Site Web

Re : Disfonctionnements dans les réactions de la galerie

Salut,

Est-ce qu'il y a des messages d'erreur dans la section "Incidents" ?

Hors ligne

#4 30-09-2023 23:00:06

mmag
Membre
Lieu : Toul
Inscription : 15-08-2014
Messages : 54
Site Web

Re : Disfonctionnements dans les réactions de la galerie

Merci pour votre réponse.
Il n'y a pas de message d'erreur. Sauf que le serveur ne répond pas.
Ce qu'on remarque, c'est que le disfonctionnement d'amplifie au fur et à mesure qu'on avance. On arrive une première fois jusqu'à un album et on peut voir les images, puis on ne voit plus les images, puis on ne peut plus atteindre l'album, etc.
Cela se passe sur les machines autres que la mienne, sous Windows ou sous Apple.
Sur ma machine, sous Edge, cela marche normalement.

Hors ligne

#5 30-09-2023 23:16:17

mmag
Membre
Lieu : Toul
Inscription : 15-08-2014
Messages : 54
Site Web

Re : Disfonctionnements dans les réactions de la galerie

Je viens de refaire une série de tests :
- sur ma machine sous Edge, cela marche normalement
- sur ma machine, sous Chrome, en https : je n'ai pas de liens sur les vignettes des catégories, je ne peut pas me loguer
- sur ma machine, sous Chrome, en http : je peux entrer dans une catégorie, un album, mais depuis la vignette, je n'atteins pas l'image. Si je veux me loguer (sous un autre nom que l'administrateur principal, logué sous Edge) la validation de la connexion aboutit à un signal PHP error, sans préciser l'erreur.
- sur ma machine, sous FireFox, même fonctionnement que sous Chrome, sauf que quand je veux me loguer sous l'utilisateur David, la machine cherche mais ne donne pas de résultat. Au bout de  mn, voilà le message :

Erreur du serveur interne
Le serveur a rencontré une erreur interne ou mal configuration et n'a pas été en mesure de compléter votre demande.
Prière de contacter l'administrateur du serveur à l'adresse suivante: [hors adresse donnée) pour les informer du moment où cette erreur s'est produite, et les actions que vous avez effectuées juste avant cette erreur.
De plus amples informations sur cette erreur peuvent être disponibles. dans le journal des erreurs du serveur.
Serveur Apache/2.4.7 (Ubuntu) à galerienew.gpmt.fr Port 80

Merci de m'aider à trouver la solution.
Cordialement.

Hors ligne

#6 23-10-2023 19:30:10

gilisa
Membre
Lieu : Région parisienne (sud)
Inscription : 23-04-2012
Messages : 227
Site Web

Re : Disfonctionnements dans les réactions de la galerie

Bonjour,

Quand tu dis "sur ma machine sous Edge cela marche normalement"
C'est sur ta machine personnelle en local ou sur ta dedibox en local ?

Il y a un soucis chez ton FAI, ça rame depuis un lien fibre Free ou un lien fibre
Orange, ça ce n'est pas normal et quelque part ta machine distante doit partir
en timeout, mais ce n'est pas du ressort d'iGalerie c'est plutot un soucis chez
ton FAI, si tu as du support soumets leur le problème.
Depuis mes liens effectivement ça coince et ça part en timeout, c'est surement
pour cette raison que iGalerie n'indique pas d'erreur.

Cdlt.
GGA.

Hors ligne

#7 23-10-2023 19:40:09

gilisa
Membre
Lieu : Région parisienne (sud)
Inscription : 23-04-2012
Messages : 227
Site Web

Re : Disfonctionnements dans les réactions de la galerie

Re,
Je confirme ton serveur a des soucis il part en timeout, il faut aller voir dans les
logs d'Apache ou du système. HS ici, désolé.

Bonne chance.
GGA.

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at [no address given] to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Hors ligne

#8 23-10-2023 23:05:54

mmag
Membre
Lieu : Toul
Inscription : 15-08-2014
Messages : 54
Site Web

Re : Disfonctionnements dans les réactions de la galerie

Merci pour votre aide.

Voici un résumé de mes problèmes :
Sur ma machine en local, sous Edge, la Galerie fonctionne normalement. Mais, sous FireFox ou Chrome, elle disfonctionne. Les réactions sont différentes suivant que la liaison est http ou https.

Les soucis que je rencontre sont sur IGalerie, galerie.gpmt.fr qui tourne encore sur php7.3
Je dispose de ma galerie perso (galerie.mimagnier.fr) qui tourne sous php 8.1.
Les deux galeries tournent sur Scalway, gpmt sur l'ancien contract Online Pro, ma galerie sous Scalway Dedibox Elementaire.
Je vais remonter les infos chez Scalway. Mais, je pense qu'on a peu de chance de voir les choses évoluer puisqu'ils abandonnent les ressources Online. Et comme cela marche normalement sur les nouvelles versions d'hébergement, je pense qu'ils ne vont pas se casser la tête.
Néanmoins, je vais remonter l'information.
Je donnerai les résultats.

Pour l'instant, le choix est porté sur le fait de basculer l'ancien hébergement Online Pro vers le nouvel hébergement Scalway Elementaire.

Merci encore pour votre recherche.

Cordialement.

Michel MAGNIER

Dernière modification par mmag (23-10-2023 23:13:23)

Hors ligne

#9 24-10-2023 17:00:22

gilisa
Membre
Lieu : Région parisienne (sud)
Inscription : 23-04-2012
Messages : 227
Site Web

Re : Disfonctionnements dans les réactions de la galerie

mmag a écrit :

Pour l'instant, le choix est porté sur le fait de basculer l'ancien hébergement Online Pro vers le nouvel hébergement Scalway Elementaire.

Si vous avez un problème SSL sur Ubuntu un tuto qui peut vous aider
https://www.digitalocean.com/community/ … untu-20-04
Attention si vous utilisez Let’s Encrypt client certbot, il est préférable d'utiliser des fournisseurs qui sont
listé sur Certbot et votre fournisseur ne l'est pas encore sad https://certbot.eff.org/hosting_providers
Online.net a des soucis en revanche OVH a tout au vert chez eux wink mais ce n'est peut-être pas le même
prix. smile
Bonne chance.
GGA.

Hors ligne

Pied de page des forums